summaryrefslogtreecommitdiff
path: root/sys-process/criu/criu-3.18.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/criu/criu-3.18.ebuild')
-rw-r--r--sys-process/criu/criu-3.18.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/sys-process/criu/criu-3.18.ebuild b/sys-process/criu/criu-3.18.ebuild
index 4dcfb79c1ff1..be93c33e7d03 100644
--- a/sys-process/criu/criu-3.18.ebuild
+++ b/sys-process/criu/criu-3.18.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{9..11} )
DISTUTILS_USE_PEP517=setuptools
-inherit toolchain-funcs linux-info distutils-r1
+inherit fcaps toolchain-funcs linux-info distutils-r1
DESCRIPTION="utility to checkpoint/restore a process tree"
HOMEPAGE="
@@ -61,6 +61,10 @@ PATCHES=(
"${FILESDIR}/criu-3.18-buildsystem.patch"
)
+FILECAPS=(
+ cap_checkpoint_restore usr/bin/criu
+)
+
criu_arch() {
# criu infers the arch from $(uname -m). We never want this to happen.
case ${ARCH} in