summaryrefslogtreecommitdiff
path: root/sys-process/btop/btop-1.2.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/btop/btop-1.2.8.ebuild')
-rw-r--r--sys-process/btop/btop-1.2.8.ebuild13
1 files changed, 13 insertions, 0 deletions
diff --git a/sys-process/btop/btop-1.2.8.ebuild b/sys-process/btop/btop-1.2.8.ebuild
index b4ac52c9fecc..ee0bbdefbd6d 100644
--- a/sys-process/btop/btop-1.2.8.ebuild
+++ b/sys-process/btop/btop-1.2.8.ebuild
@@ -13,6 +13,19 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 arm64 ppc64 ~riscv x86"
+BDEPEND="
+ >=sys-devel/gcc-8
+"
+
+pkg_setup() {
+ if [[ "${MERGE_TYPE}" != "binary" ]]; then
+ if ! tc-is-gcc ; then
+ # https://bugs.gentoo.org/839318
+ die "$(tc-getCXX) is not a supported compiler. Please use sys-devel/gcc instead."
+ fi
+ fi
+}
+
src_prepare() {
default
# btop installs README.md to /usr/share/btop by default