summaryrefslogtreecommitdiff
path: root/sys-process/atop/files/atop-2.7.0-netatop-makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/atop/files/atop-2.7.0-netatop-makefile.patch')
-rw-r--r--sys-process/atop/files/atop-2.7.0-netatop-makefile.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-process/atop/files/atop-2.7.0-netatop-makefile.patch b/sys-process/atop/files/atop-2.7.0-netatop-makefile.patch
new file mode 100644
index 000000000000..bd2f17658cf8
--- /dev/null
+++ b/sys-process/atop/files/atop-2.7.0-netatop-makefile.patch
@@ -0,0 +1,42 @@
+--- a/daemon/Makefile
++++ b/daemon/Makefile
+@@ -6,7 +6,7 @@
+ all: netatopd
+
+ netatopd: netatopd.o Makefile
+- $(CC) netatopd.o -o netatopd -lz
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) netatopd.o -o netatopd -lz
+
+ clean:
+ rm -f *.o netatopd
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,7 @@
+ all:
+ ./mkversion
+- cd module; make
+- cd daemon; make
++ cd module; $(MAKE)
++ cd daemon; $(MAKE)
+
+ install: module/netatop.ko daemon/netatopd
+ install -d /lib/modules/`uname -r`/extra
+@@ -14,5 +14,5 @@
+ install man/netatopd.8 -t /usr/share/man/man8
+
+ clean:
+- cd module; make clean
+- cd daemon; make clean
++ cd module; $(MAKE) clean
++ cd daemon; $(MAKE) clean
+--- a/module/Makefile
++++ b/module/Makefile
+@@ -7,7 +7,7 @@
+
+ $(MYMODULE).ko: $(MYMODULE).c
+ echo start the make
+- make -C $(KERNDIR) M=$(THISDIR) modules
++ $(MAKE) -C $(KERNDIR) M=$(THISDIR) modules
+
+ clean:
+ rm -f *.o *.ko