summaryrefslogtreecommitdiff
path: root/sys-libs
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/Manifest.gzbin14752 -> 14741 bytes
-rw-r--r--sys-libs/libcap/Manifest1
-rw-r--r--sys-libs/libcap/libcap-2.69-r1.ebuild94
-rw-r--r--sys-libs/pam/Manifest1
-rw-r--r--sys-libs/pam/pam-1.5.3-r1.ebuild153
-rw-r--r--sys-libs/pam_wrapper/Manifest1
-rw-r--r--sys-libs/pam_wrapper/pam_wrapper-1.1.4-r3.ebuild88
-rw-r--r--sys-libs/timezone-data/Manifest2
-rw-r--r--sys-libs/timezone-data/timezone-data-2023d.ebuild2
-rw-r--r--sys-libs/zlib/Manifest4
-rw-r--r--sys-libs/zlib/zlib-1.3-r4.ebuild (renamed from sys-libs/zlib/zlib-1.3-r3.ebuild)3
-rw-r--r--sys-libs/zlib/zlib-1.3.1-r1.ebuild (renamed from sys-libs/zlib/zlib-1.3.1.ebuild)3
12 files changed, 344 insertions, 8 deletions
diff --git a/sys-libs/Manifest.gz b/sys-libs/Manifest.gz
index ea8734c7e109..ddae5e557112 100644
--- a/sys-libs/Manifest.gz
+++ b/sys-libs/Manifest.gz
Binary files differ
diff --git a/sys-libs/libcap/Manifest b/sys-libs/libcap/Manifest
index 95625224b030..d7e619e563ba 100644
--- a/sys-libs/libcap/Manifest
+++ b/sys-libs/libcap/Manifest
@@ -1,5 +1,6 @@
AUX libcap-2.62-ignore-RAISE_SETFCAP-install-failures.patch 724 BLAKE2B 39b2924071c9c6b1ffba3acf2fbeea6196c20da175ed4a5ddd6fac5375d604df3823bf183c36da6eb03e1b9cd918d107fd7e5b30f2f3746ce17b589a77f3dec5 SHA512 11ca33d7f1a352cce9dad179be415b6282efdbb9049a92ba945cbfbee2b6c263af39adb3a93f62e5077d9b33e0f098f9125362432bd333601345d8c3671d40bd
DIST libcap-2.69.tar.xz 189200 BLAKE2B 94d1fef7666a1c383a8b96f1f6092bd242164631532868b628d2f5de71b42a371d041a978ef7fbadfee3eeb433165444995d1078cd790275bc0433a7875a697e SHA512 647c307dc451517da9d089495ab959b4a6fbbe41c79f4e1e9bb663569dad630ead0c2e413dfb393319e3ea14dc9848c81b392107fe3382ce1813d278c3394a7f
+EBUILD libcap-2.69-r1.ebuild 2188 BLAKE2B c090d7a6d384cb1e0298b57eb3ff5ff36912b6dc68995058df2cd12a30b83e9ebbfb37738f248e67e57c68baf2ea3f2f5d1572d4d093b9c56db47f6289d6f28f SHA512 ec9fb399a62a915d2626835e0edfdcea841642ea93d4f0531294832b29bee000f973e96659a8bdebf96c6b541b3c67d5add8edc25acc1fe1ec12d39e6e925e6f
EBUILD libcap-2.69.ebuild 2243 BLAKE2B 429e44f61da99bdf3ca07e0282a191fff0db4c4c572850e6815a28cf1e6cb36b1ff571986ce1a5f048e089fb3f46a986edd3dc5501addf790e717670a91d9c04 SHA512 4ccc020e0b500fc7f4616e4499e69cb1bcc4eff8d1958c48a07ef0be4c67034b37be35b1ec3fce9d7a066847bd30abf6ac5dfbf6f173cddcbf0ba34f1e777d4b
EBUILD libcap-9999.ebuild 2251 BLAKE2B f18956d67d59dfb12654b0f6f8b1e607ac993318ba52722dc3c45bb922c42e530daf1f3c8eb3174c72817f98085fe7757eb0aba151c0540143accf41bceb49c1 SHA512 3ee464d81cdc2243d5289f64e390c886d9b70a10120a19eceb75d017ca467e0f2cc99a40107115d249146c27dbb8d2f22df72910dfc330058e6b580a1fd8ca1c
MISC metadata.xml 438 BLAKE2B b5260cc84a3fe6b992bb6218846c738af296522d7a467337c05a6240fd07fc9d6cece779bd9fcf24a11486a70874e17acae8182647d307a31cf43e1c19c3a2d3 SHA512 fa3713dcf6b7bb2ea6d4c2fdefc05e92ae345c76a6187ebcb40dab8c4ce0148650a8301f236efcb8cf53fff25730977a385578dbaa160b800159c6d6abbf37a9
diff --git a/sys-libs/libcap/libcap-2.69-r1.ebuild b/sys-libs/libcap/libcap-2.69-r1.ebuild
new file mode 100644
index 000000000000..ee91b8f42d9c
--- /dev/null
+++ b/sys-libs/libcap/libcap-2.69-r1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal toolchain-funcs pam
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/libs/libcap/libcap.git"
+else
+ SRC_URI="https://www.kernel.org/pub/linux/libs/security/linux-privs/libcap2/${P}.tar.xz"
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="POSIX 1003.1e capabilities"
+HOMEPAGE="https://sites.google.com/site/fullycapable/"
+
+# it's available under either of the licenses
+LICENSE="|| ( GPL-2 BSD )"
+SLOT="0"
+IUSE="pam static-libs tools"
+
+# While the build system optionally uses gperf, we don't DEPEND on it because
+# the build automatically falls back when it's unavailable. #604802
+PDEPEND="pam? ( sys-libs/pam[${MULTILIB_USEDEP}] )"
+DEPEND="${PDEPEND}
+ sys-kernel/linux-headers"
+BDEPEND="
+ sys-apps/diffutils
+ tools? ( dev-lang/go )"
+
+QA_FLAGS_IGNORED="sbin/captree" # go binaries don't use LDFLAGS
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.62-ignore-RAISE_SETFCAP-install-failures.patch
+)
+
+src_prepare() {
+ default
+ multilib_copy_sources
+}
+
+run_emake() {
+ local args=(
+ AR="$(tc-getAR)"
+ CC="$(tc-getCC)"
+ OBJCOPY="$(tc-getOBJCOPY)"
+ RANLIB="$(tc-getRANLIB)"
+ exec_prefix="${EPREFIX}"
+ lib_prefix="${EPREFIX}/usr"
+ lib="$(get_libdir)"
+ prefix="${EPREFIX}/usr"
+ PAM_CAP="$(usex pam yes no)"
+ DYNAMIC=yes
+ GOLANG="$(multilib_native_usex tools yes no)"
+ )
+ emake "${args[@]}" "$@"
+}
+
+src_configure() {
+ tc-export_build_env BUILD_CC
+ multilib-minimal_src_configure
+}
+
+multilib_src_compile() {
+ run_emake
+}
+
+multilib_src_test() {
+ run_emake test
+}
+
+multilib_src_install() {
+ # no configure, needs explicit install line #444724#c3
+ run_emake DESTDIR="${D}" install
+
+ if ! use static-libs ; then
+ rm "${ED}"/usr/$(get_libdir)/lib{cap,psx}.a || die
+ fi
+
+ # install pam plugins ourselves
+ rm -rf "${ED}"/usr/$(get_libdir)/security || die
+
+ if use pam ; then
+ dopammod pam_cap/pam_cap.so
+ dopamsecurity '' pam_cap/capability.conf
+ fi
+}
+
+multilib_src_install_all() {
+ dodoc CHANGELOG README doc/capability.md
+}
diff --git a/sys-libs/pam/Manifest b/sys-libs/pam/Manifest
index 845831b976f1..ce6ebbbc198a 100644
--- a/sys-libs/pam/Manifest
+++ b/sys-libs/pam/Manifest
@@ -1,5 +1,6 @@
AUX pam-1.5.3-termios.patch 913 BLAKE2B 3fdb9c6320c56fd2c10b76b58700263a1c190dde4a62bb33fdfe2e59e2aebedffe87bd14fb7f02ca9c3df8f9ca21af13a1e5b42cd4eb0b112bb03f311e975288 SHA512 c432af010b188ff8a3f1fb08cc7e68b12651f8a2592fa43c5aec8c60e938c04a62ae67bc0fdb6704df3ec39aa3b40a56c1abbf07e0e5105a7b7ca4af7e44c715
DIST Linux-PAM-1.5.3-docs.tar.xz 466340 BLAKE2B 6bade3c63ebe6b6ca7a86d7385850bb87bf1d6526add3ac5aad140533516c1d27b594a17d09c4127ff985c42e6c571618785d6b2a2913e6575678c4dcf947dc0 SHA512 a9082823da88e0054d74e13aef872519ced5fbef25c8cc1a7e3a99160f835aa09c9ef701b6ec507acd3b540da0019288424bb4c8ebd828181ea90450db1494a9
DIST Linux-PAM-1.5.3.tar.xz 1020076 BLAKE2B 362c939f3afc343e6f4e78e7f6ba6f7a9c6ee0a9948bb5a4fc34cecfd29e9fa974082534d4ceedd04d8d3e34c7b3ef43d2a07ba5f41d26da04ec8330fc3790fb SHA512 af88e8c1b6a9b737ffaffff7dd9ed8eec996d1fbb5804fb76f590bed66d8a1c2c6024a534d7a7b6d18496b300f3d6571a08874cf406cd2e8cea1d5eff49c136a
+EBUILD pam-1.5.3-r1.ebuild 4442 BLAKE2B f0cd9ae58e1c315fb9d9b92ec07cd2f9bde6a4bbd86bbb54920c2b32f659760eea3f3cfc56d6e217dfa6da921a2ebac4b5123d505dfc49bc1bbcae600d8e15f7 SHA512 ad05e3e1cb6f7908499a2d59b35fbcd8f20223c86a28e2c8b0f5c97a433bddc5a0e5e4767e51441bc65f76bf8dbabc167de92c2c0ad75fe6f545dbbd3bb159c7
EBUILD pam-1.5.3.ebuild 4487 BLAKE2B df92ac6e275d0e1b5c881eeca87a10aade04fcfe7f4db37d7da72ace5c878be0858272a5eba57da2237662b674f8e7eb8c810cb2e48c1bf41944dccdddc86b87 SHA512 0fee84d5efab16672b8cbb2eee4802b2d12020ca6b07186f1510f05467dfebfbaf627733fcb67eb2cf04acb5f935ce5ebe26e467e17d349e57b17f8065438272
MISC metadata.xml 846 BLAKE2B e236bd8c7a53097d96164d9063d1dbb9372cef4ec92731dc43df6731cc7f4fc2935aeeb2e069b6da1d4bce3f1cc6a657e0361208581da615f3f41ec72c02261e SHA512 e2e28deadb2c941f8fa31447ec20c95ccb340d638f8b1e742a89ccc2dbb3c8d88e764f750d6e13c5a6320a612d6f2447689c02862a5e897919d1e9bca7857089
diff --git a/sys-libs/pam/pam-1.5.3-r1.ebuild b/sys-libs/pam/pam-1.5.3-r1.ebuild
new file mode 100644
index 000000000000..8f176361a930
--- /dev/null
+++ b/sys-libs/pam/pam-1.5.3-r1.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="Linux-${PN^^}-${PV}"
+
+# Avoid QA warnings
+# Can reconsider w/ EAPI 8 and IDEPEND, bug #810979
+TMPFILES_OPTIONAL=1
+
+inherit db-use fcaps flag-o-matic toolchain-funcs multilib-minimal
+
+DESCRIPTION="Linux-PAM (Pluggable Authentication Modules)"
+HOMEPAGE="https://github.com/linux-pam/linux-pam"
+SRC_URI="
+ https://github.com/linux-pam/linux-pam/releases/download/v${PV}/${MY_P}.tar.xz
+ https://github.com/linux-pam/linux-pam/releases/download/v${PV}/${MY_P}-docs.tar.xz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="audit berkdb debug nis selinux"
+
+BDEPEND="
+ app-alternatives/yacc
+ dev-libs/libxslt
+ app-alternatives/lex
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+DEPEND="
+ virtual/libcrypt:=[${MULTILIB_USEDEP}]
+ >=virtual/libintl-0-r1[${MULTILIB_USEDEP}]
+ audit? ( >=sys-process/audit-2.2.2[${MULTILIB_USEDEP}] )
+ berkdb? ( >=sys-libs/db-4.8.30-r1:=[${MULTILIB_USEDEP}] )
+ selinux? ( >=sys-libs/libselinux-2.2.2-r4[${MULTILIB_USEDEP}] )
+ nis? (
+ net-libs/libnsl:=[${MULTILIB_USEDEP}]
+ >=net-libs/libtirpc-0.2.4-r2:=[${MULTILIB_USEDEP}]
+ )
+"
+RDEPEND="${DEPEND}"
+PDEPEND=">=sys-auth/pambase-20200616"
+
+PATCHES=(
+ "${FILESDIR}/${P}-termios.patch"
+)
+
+src_prepare() {
+ default
+ touch ChangeLog || die
+}
+
+multilib_src_configure() {
+ # Do not let user's BROWSER setting mess us up, bug #549684
+ unset BROWSER
+
+ # This whole weird has_version libxcrypt block can go once
+ # musl systems have libxcrypt[system] if we ever make
+ # that mandatory. See bug #867991.
+ if use elibc_musl && ! has_version sys-libs/libxcrypt[system] ; then
+ # Avoid picking up symbol-versioned compat symbol on musl systems
+ export ac_cv_search_crypt_gensalt_rn=no
+
+ # Need to avoid picking up the libxcrypt headers which define
+ # CRYPT_GENSALT_IMPLEMENTS_AUTO_ENTROPY.
+ cp "${ESYSROOT}"/usr/include/crypt.h "${T}"/crypt.h || die
+ append-cppflags -I"${T}"
+ fi
+
+ local myconf=(
+ CC_FOR_BUILD="$(tc-getBUILD_CC)"
+ --with-db-uniquename=-$(db_findver sys-libs/db)
+ --with-xml-catalog="${EPREFIX}"/etc/xml/catalog
+ --enable-securedir="${EPREFIX}"/$(get_libdir)/security
+ --includedir="${EPREFIX}"/usr/include/security
+ --libdir="${EPREFIX}"/usr/$(get_libdir)
+ --enable-pie
+ --enable-unix
+ --disable-prelude
+ --disable-doc
+ --disable-regenerate-docu
+ --disable-static
+ --disable-Werror
+ # TODO: wire this up now it's more useful as of 1.5.3
+ --disable-econf
+
+ # TODO: add elogind support
+ # lastlog is enabled again for now by us until logind support
+ # is handled. Even then, disabling lastlog will probably need
+ # a news item.
+ --disable-logind
+ --enable-lastlog
+
+ $(use_enable audit)
+ $(use_enable berkdb db)
+ $(use_enable debug)
+ $(use_enable nis)
+ $(use_enable selinux)
+ --enable-isadir='.' # bug #464016
+ )
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+}
+
+multilib_src_compile() {
+ emake sepermitlockdir="/run/sepermit"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install \
+ sepermitlockdir="/run/sepermit"
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f -name '*.la' -delete || die
+
+ # tmpfiles.eclass is impossible to use because
+ # there is the pam -> tmpfiles -> systemd -> pam dependency loop
+ dodir /usr/lib/tmpfiles.d
+
+ cat ->> "${D}"/usr/lib/tmpfiles.d/${CATEGORY}-${PN}.conf <<-_EOF_
+ d /run/faillock 0755 root root
+ _EOF_
+ use selinux && cat ->> "${D}"/usr/lib/tmpfiles.d/${CATEGORY}-${PN}-selinux.conf <<-_EOF_
+ d /run/sepermit 0755 root root
+ _EOF_
+
+ local page
+
+ for page in doc/man/*.{3,5,8} modules/*/*.{5,8} ; do
+ doman ${page}
+ done
+}
+
+pkg_postinst() {
+ ewarn "Some software with pre-loaded PAM libraries might experience"
+ ewarn "warnings or failures related to missing symbols and/or versions"
+ ewarn "after any update. While unfortunate this is a limit of the"
+ ewarn "implementation of PAM and the software, and it requires you to"
+ ewarn "restart the software manually after the update."
+ ewarn ""
+ ewarn "You can get a list of such software running a command like"
+ ewarn " lsof / | grep -E -i 'del.*libpam\\.so'"
+ ewarn ""
+ ewarn "Alternatively, simply reboot your system."
+
+ # The pam_unix module needs to check the password of the user which requires
+ # read access to /etc/shadow only.
+ fcaps cap_dac_override sbin/unix_chkpwd
+}
diff --git a/sys-libs/pam_wrapper/Manifest b/sys-libs/pam_wrapper/Manifest
index 3f199ebe76b2..0651126ab889 100644
--- a/sys-libs/pam_wrapper/Manifest
+++ b/sys-libs/pam_wrapper/Manifest
@@ -1,4 +1,5 @@
AUX pam_wrapper-1.1.4-tests-import.patch 767 BLAKE2B 65ce88028190bbbd3aacdf0a3af7591ebe90e4c24fb3502ef631ee8b126377cc6fe2a8a124658d5624e569235c9d48751e1f8142dbb87f5179d6017647991f3c SHA512 420704520ef5e4d6e1a5f4fca64619ab29765e9a5ddd347d1fc5427664e212695b6c19d7c15fe787f7375570378a261fab99c2b345ff7e96f3a7aaaf35e51939
DIST pam_wrapper-1.1.4.tar.gz 170882 BLAKE2B fa0a789f6fd6f809c7ef80e354e886b5f1f0b4212060dc0e388a44701e4a1f49635b8f47344156ad65cd273660e3b0a806480c37875a830e2f5d8e56c4ec0818 SHA512 3b68dc6d7815707d74d1340facd9c2de4dff3934402ac2c2632371b39c41a75744434744ed7308e157be03a03a941405638cadb6f34995de56fb1f5f45d37de2
EBUILD pam_wrapper-1.1.4-r2.ebuild 2010 BLAKE2B ef4899552b056ad449715435c4c63af45850b7cbaf77b1a67cb6d26b951be40d9554ae7b1f9d9f83ee94cc9c813dad24860d18da494166debfd63a4f6e47c05c SHA512 c88b8893bba01151a9bb3315538ae437eb34e4b6cf66351dca2ebbcbfddba014a601424a87a55d1be00ab1538929f29d212cc35e0605e1010decf3446218089c
+EBUILD pam_wrapper-1.1.4-r3.ebuild 2017 BLAKE2B 2635a3dbd0b51989e46d3695f63123b68c89758b8b3840b61b4021eecc7e99124e6d3cb3e9f17f92327dd3dae2231ed898df4fcf1b638a2221cfdd453730cacb SHA512 9d294b598a814f8243e64ce5e22076c806304969bb2dfb5600606548d48c55fd84dc5e27db82ee87559ad4e1a58049abb15899ead515975e0db3e28fc92a8998
MISC metadata.xml 250 BLAKE2B e398673dd1a3522ccddb89a82a53fc2578d8e0777ec46f889d01d618609a22958d91699beef513c7912799e0e8ff985200f7c67bba941235da25c24cd4b48f09 SHA512 16834c3cbecd0dd5a9c8c311d2b8ebc63d8cd72c5891498f4f0048988993c104aadd4e24e632bf54071c11f810716432e89e4afab029555875f9f52794daa6e9
diff --git a/sys-libs/pam_wrapper/pam_wrapper-1.1.4-r3.ebuild b/sys-libs/pam_wrapper/pam_wrapper-1.1.4-r3.ebuild
new file mode 100644
index 000000000000..7804b800ce5d
--- /dev/null
+++ b/sys-libs/pam_wrapper/pam_wrapper-1.1.4-r3.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit cmake-multilib python-r1
+
+DESCRIPTION="A tool to test PAM applications and PAM modules"
+HOMEPAGE="https://cwrap.org/pam_wrapper.html"
+SRC_URI="
+ https://www.samba.org/ftp/pub/cwrap/${P}.tar.gz
+ https://ftp.samba.org/pub/cwrap/${P}.tar.gz
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Require newer PAM so we know where it's located, bug #825078
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=sys-libs/pam-1.5.3-r1:0=[${MULTILIB_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-util/cmocka[${MULTILIB_USEDEP}] )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.4-tests-import.patch
+)
+
+multilib_src_configure() {
+ configure_for_python() {
+ local mycmakeargs=( -DUNIT_TESTING=OFF )
+ cmake_src_configure
+ }
+
+ if multilib_is_native_abi ; then
+ # Build the Pythons for each version (but only for the native ABI)
+ # bug #737468
+ python_foreach_impl configure_for_python
+ fi
+
+ # Do the regular build now
+ local mycmakeargs=(
+ -DUNIT_TESTING=$(usex test)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Python{Libs,Interp,SiteLibs}=ON
+ )
+ cmake_src_configure
+}
+
+multilib_src_compile() {
+ if multilib_is_native_abi ; then
+ python_foreach_impl cmake_src_compile
+ fi
+
+ # Compile the "proper" version without Python last
+ cmake_src_compile
+}
+
+multilib_src_test() {
+ cmake_src_test
+
+ # Fails b/c of sandbox?
+ #python_test() {
+ # local -x PYTHONPATH="${BUILD_DIR}/src/python/python3:${PYTHONPATH}"
+ # elog "${PYTHONPATH}"
+ # ${EPYTHON} "${S}"/tests/pypamtest_test.py || die "Tests failed with ${EPYTHON}"
+ #}
+
+ #if multilib_is_native_abi ; then
+ # python_foreach_impl python_test
+ #fi
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi ; then
+ python_foreach_impl cmake_src_install
+ fi
+
+ # Install the "proper" version without Python last
+ cmake_src_install
+}
diff --git a/sys-libs/timezone-data/Manifest b/sys-libs/timezone-data/Manifest
index 106c7c8e54f8..dc002157fc80 100644
--- a/sys-libs/timezone-data/Manifest
+++ b/sys-libs/timezone-data/Manifest
@@ -5,6 +5,6 @@ DIST tzdata2023c.tar.gz 443902 BLAKE2B 8a50aa5f338565d86b8fa5428c138b251bd8dcc3e
DIST tzdata2023d.tar.gz 449767 BLAKE2B b79be37a8a258745d162a575c795ee6476b4fa5f6d2f7b562d9431a238eca276a1747a983778291184fc6e40a0c1f5e6284d41290fd6d1d3bd3118bda83f426e SHA512 81832b2d738c28cecbcb3906cc07568c5ae574adc9de35b25d4bf613581c92d471d67213b4261a56f0ec02efcf211b4e298b7e1dc367c972e726b0a2e9498df4
DIST tzdata2024a.tar.gz 451270 BLAKE2B 5ec49bbce704411a1d8b3f018b0d8f6c7de24c5600e0cb6c61a7ee29b4a49b1e502d23b40bce6584ea0aa9b66327321608cbabb994071ec4ca2b3a496aa2d621 SHA512 1f09f1b2327cc9e1afc7e9045e83ee3377918dafe1bee2f282b6991828d03b3c70a4d3a17f9207dfb1361bb25bc214a8922a756e84fa114e9ba476226db57236
EBUILD timezone-data-2023c-r1.ebuild 5320 BLAKE2B e7bb8b3bebb6905690232f2fe238ef7f234c2052cac3d33091a5d924448e9b389f0a167e4f27936c05c527ca553bad36694c1da67c8cd2b0b02fb90176ed9f7a SHA512 113218d4b499a5bdece7fc4241e48d4bd63fe3a1cea9d4ae8f3726d32615901dd0bc5587cdfdfd6a13a75337c84bbff3193aaab7c359b994e48a3099bf298c4f
-EBUILD timezone-data-2023d.ebuild 5275 BLAKE2B 4e1607c4d189f16e1748b4e5726b9c66138834259f37be50a71509bf9574b4353edfbc1a85ea11aa818b9d2dfc22656f4a5590899e5118b0d1d75d5e00b5f3bd SHA512 1c46e78290f1fb3191de085b1ef560da005f334b0e03fea4cf31a2661d932a63300e3d7ad34dfb9420d8f049fb89b4fb0dec3fcc104e6723aec48819113f4972
+EBUILD timezone-data-2023d.ebuild 5274 BLAKE2B f105cd30b039b31e3ca213711c65db387c730135503b8a5633db29ab1d61eebe4e26457326e16269a5735087a77c6c1386304b15c905b338655347e98fccf3fa SHA512 606844ea9605847a3c0ca6fa03cc5151443634fd8c475e9b0a6a4dd936c2ac2dbc012978a6d67d29cdf08f14cdcafff5fe633b5f6e41b9e08e0c17fda8f0c5e7
EBUILD timezone-data-2024a.ebuild 5282 BLAKE2B e27c6baa5e5824019426ce1c941d0f801e7e1191e3da989d275fd1797e0510859653fbe792b763f31bc2d90fce477a5ebda8e28642b5576ff594a2c696a82665 SHA512 844a6b7800ed758de9f251665de5be9f24d8599eea66be82b26ede14188cd82a9f837dd97ddd6d2a663826b6c8c7c15b322909717b32e6398a79511c2fca0cc5
MISC metadata.xml 807 BLAKE2B 24b09c4228c232b607e6e6c165a20e364136d77aa970e72c70124636a038cd3b672bad16ddd68c0b75373be6a09f969e59bc38f7e451bb2869cd46c521e2ca82 SHA512 0b95b32d79651493a04032f175f3320d8975cea714b43fa56aa528f10f51a7c52b58a934828f98a770855485af6f8db048bd2bfa3010802cff8c26ae05bb16e2
diff --git a/sys-libs/timezone-data/timezone-data-2023d.ebuild b/sys-libs/timezone-data/timezone-data-2023d.ebuild
index 2e6109489b5f..92d625f298e2 100644
--- a/sys-libs/timezone-data/timezone-data-2023d.ebuild
+++ b/sys-libs/timezone-data/timezone-data-2023d.ebuild
@@ -14,7 +14,7 @@ SRC_URI="https://www.iana.org/time-zones/repository/releases/tzdata${MY_DATA_VER
LICENSE="BSD public-domain"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
IUSE="nls leaps-timezone zic-slim"
DEPEND="nls? ( virtual/libintl )"
diff --git a/sys-libs/zlib/Manifest b/sys-libs/zlib/Manifest
index 8645a1ab92b1..326764dec111 100644
--- a/sys-libs/zlib/Manifest
+++ b/sys-libs/zlib/Manifest
@@ -11,6 +11,6 @@ DIST zlib-1.3.1.tar.xz.asc 235 BLAKE2B b135336ef55a0c4b8e219e760bbe04bad082c4052
DIST zlib-1.3.tar.xz 1295740 BLAKE2B 5fe0f32339267348a313f23a21e9588bdb180b7415be303c85f5f169444d019e5f176ef7322f6e64297c360acc2a6041c50e2f66d1860e5c392d8970990f176a SHA512 3868ac4da5842dd36c9dad794930675b9082ce15cbd099ddb79c0f6bd20a24aa8f33a123f378f26fe0ae02d91f31f2994dccaac565cedeaffed7b315e6ded2a2
DIST zlib-1.3.tar.xz.asc 235 BLAKE2B 5fe6ce952699a19e848d0a6e6c3622f934340068fdcd29afb35c74f3c8ae66d04de644800d10b38c743bb2f4852ba28f1a97313cb0e6e6f9b804cbca5289ebbb SHA512 8f3ce5c21938d6abc7e121d2939648a0ce2dc01a8ab4eb001d44eb159935dd0b4f5b5e371b3ecfc0ceb23689e2cefe002065968908503cde15b1bba08aff9db6
EBUILD zlib-1.3-r2.ebuild 4621 BLAKE2B 58c6f3a494919167a0314e47c3af83ba2aad965c4180e6943455a87500e88a5d51473903e0d0addf3b0282ac189115f38dee8816ca1984ab81e1938e418f708a SHA512 3a50e51a9b293fe802f4bb359631ba28d5262ce8a7dc0e6ca79abf8360fce6ab9cdaeea901c40d93113da3c99d0db912c356ab741314a34d6bf2d6475e23b926
-EBUILD zlib-1.3-r3.ebuild 4405 BLAKE2B 7f12a09d0fdd0f586bba579c6b5f08a44a0a55f03c9dbca3439120842b57b5c06ece2299e2bd8b16bf23bb0914b783acc2d9f86a282f732f9ffecbb3023fa8d4 SHA512 246cbf349c516d0bc4d5026ebf26c90dacf4bc831d9c828b98a0a70b92cef63b5efe978bf5ea9b63a7eff008feb48b3b7ebc850fdd5c6d1b474e4f25a5fa59f2
-EBUILD zlib-1.3.1.ebuild 4327 BLAKE2B ecc4e1669c0f146e06d958ebd265e4416b85b2924e152b4183cf3407056a06f945dfba05f60c7fc0136ada1b46b194401027a7bb67dbe91cc5e7df4dcdfc4cd0 SHA512 9547b96b1a324f5fc1c767c6a6e9ca538dcba7ce8b897db894de1d77b736703d9a8f437c7184fa53183451b342764d0f89590aae316f420f1ce82dc7e3895dad
+EBUILD zlib-1.3-r4.ebuild 4367 BLAKE2B b6b3d5ef1a56eff65c3430c5cf0b93ded7065d7ea050a806419d954590df74a3a46098a96aca71cf558e6f99535d10a8dd9fd39425d7a9422818f40f5c363e96 SHA512 8cffd0c46e698ab5cc67d57b8004d17735a4a2386326cc7cc0cae4b1d824c576fa552c5f9dd238b7b0e12d5c6e51b30b1bc8c983ccca92c25b7bb9bbf7903296
+EBUILD zlib-1.3.1-r1.ebuild 4289 BLAKE2B 6f136a0b8239eaa7e02a7349d3e103cad06d45019ed38a73c578165c48c4f55fd0fea4a485ba5720ac676ecded74d5dc42284b778befd6c5515189fc3c99710c SHA512 90980a978da7066870ccd8fe8e8a0e9765c6dd790f2a1b0ec3a78e497ee5121ed0378290509be7e8eecce974cd43edd0eb3da4fc3f68f40d97858080851a6dcf
MISC metadata.xml 494 BLAKE2B a4a57a4153aefc189e407bcb8ce84f7c94581cc66967f69097087da7e6ff48d2de683b919fb00445d095c47ef39d31e01590f8c989ce0e5e01474e73ee2a0565 SHA512 a7e0160c127b3c2a6afe99e95992d9dbd017061303759c299ec38800efd6a9e11a35ae850c23c77c09c8833cd9d61ac1267f6becadf9c22437ee35e4304400c9
diff --git a/sys-libs/zlib/zlib-1.3-r3.ebuild b/sys-libs/zlib/zlib-1.3-r4.ebuild
index 1c7cc6d899c1..5ec332438f41 100644
--- a/sys-libs/zlib/zlib-1.3-r3.ebuild
+++ b/sys-libs/zlib/zlib-1.3-r4.ebuild
@@ -6,7 +6,7 @@ EAPI=8
# Worth keeping an eye on 'develop' branch upstream for possible backports.
AUTOTOOLS_AUTO_DEPEND="no"
VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/madler.asc
-inherit autotools edo multilib-minimal flag-o-matic usr-ldscript verify-sig
+inherit autotools edo multilib-minimal flag-o-matic verify-sig
DESCRIPTION="Standard (de)compression library"
HOMEPAGE="https://zlib.net/"
@@ -145,7 +145,6 @@ multilib_src_install() {
*)
emake install DESTDIR="${D}" LDCONFIG=:
- gen_usr_ldscript -a z
;;
esac
diff --git a/sys-libs/zlib/zlib-1.3.1.ebuild b/sys-libs/zlib/zlib-1.3.1-r1.ebuild
index f12a76540f6e..fb44717aca45 100644
--- a/sys-libs/zlib/zlib-1.3.1.ebuild
+++ b/sys-libs/zlib/zlib-1.3.1-r1.ebuild
@@ -6,7 +6,7 @@ EAPI=8
# Worth keeping an eye on 'develop' branch upstream for possible backports.
AUTOTOOLS_AUTO_DEPEND="no"
VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/madler.asc
-inherit autotools edo multilib-minimal flag-o-matic usr-ldscript verify-sig
+inherit autotools edo multilib-minimal flag-o-matic verify-sig
DESCRIPTION="Standard (de)compression library"
HOMEPAGE="https://zlib.net/"
@@ -142,7 +142,6 @@ multilib_src_install() {
*)
emake install DESTDIR="${D}" LDCONFIG=:
- gen_usr_ldscript -a z
;;
esac