summaryrefslogtreecommitdiff
path: root/sys-libs/tdb
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/tdb')
-rw-r--r--sys-libs/tdb/Manifest2
-rw-r--r--sys-libs/tdb/tdb-1.4.10.ebuild79
2 files changed, 81 insertions, 0 deletions
diff --git a/sys-libs/tdb/Manifest b/sys-libs/tdb/Manifest
index b750e79dc8e8..e81d663b5f22 100644
--- a/sys-libs/tdb/Manifest
+++ b/sys-libs/tdb/Manifest
@@ -1,5 +1,7 @@
+DIST tdb-1.4.10.tar.gz 747139 BLAKE2B e271f824acc8c691a6e88f5e5f73d0673a132134d025e84461520108b94cd7a5db587a0012ad1172270d29042f29336aab6ca59a735d611d6529f81ec3c195e9 SHA512 b5147d811617d90a025d1070abf16c42744b3fc3cac1042fbff03b1e635af2eaf9c957a7bffdb3f56b4a0c775b44f8027def9f23deb1b3ede817b95bbece2ce9
DIST tdb-1.4.8.tar.gz 742791 BLAKE2B dc2705cb16ee59f4d5bf25602032b25fd5338caa890db19939996a40cd19c4c999f9a74786d5754dbbd1de54d818541cf56844beeb33008aaee507d5dfcdba85 SHA512 763beebe923aa04303cbb91ce5970e6bbd13546888cff75ea9ab025afff3ef88fee539ae173fc2fb7ec661b6c337b0c2da361ce3d318f51ef6627bdb3fe6ca63
DIST tdb-1.4.9.tar.gz 746608 BLAKE2B 2cdcf636b9ef5445d48ca2aab79d4ffd137a8409b6d7b1fcdbcd28797d4bbe617f768a5ef92a14c4ae6dddfc37576f5d411cf4d67edeb4319f46a1a15ffd94ee SHA512 6b0109075826b8630f6b5a7e7ade2fcff95c5d05338340af78219422610947c520707b3e484ff13fbd40bbfffe13977976e8ddcb1be7b13e13ac78b4e3ec06c2
+EBUILD tdb-1.4.10.ebuild 1590 BLAKE2B 4d96ec2dd2c1835fb5729e2aa3d32f09fc51a9d7741c6c5253a3699fe25072534c11aa7196dacfc559c35e2e3ebfe5cff52d401c989a8c943879717668396854 SHA512 9dfca3b1c8babc18fdb52e965389266a584c5a3e828007c90d9cafa33d3503f2b30625c2fc2aa64582c4509123a383e6d3be4e3998e27f989ea5f7f72adbbc9e
EBUILD tdb-1.4.8.ebuild 1443 BLAKE2B 977a7a412c0ab6f969acdd35ea2f256d1e961a11fd20b643c7b33ed5d6155fd26a63f8457902e95df6b9a4854d1ae5d33d5f1bbcccfe4b954635188ebafc6445 SHA512 1b3c755a1e9907b41b05cbf315b14f43c1c7b64bc9eb3787e23070170f0b79d93d60b0cc6a09aaada8201f638818fbd5b4fcb228ece8938769ff2c085b554eb0
EBUILD tdb-1.4.9.ebuild 1590 BLAKE2B 4d96ec2dd2c1835fb5729e2aa3d32f09fc51a9d7741c6c5253a3699fe25072534c11aa7196dacfc559c35e2e3ebfe5cff52d401c989a8c943879717668396854 SHA512 9dfca3b1c8babc18fdb52e965389266a584c5a3e828007c90d9cafa33d3503f2b30625c2fc2aa64582c4509123a383e6d3be4e3998e27f989ea5f7f72adbbc9e
MISC metadata.xml 245 BLAKE2B 015a6303c153dcdb4a4b6ec58ea97e6798d3316c6d211559022bd2a26d481356e481ba2ade200171bb182264ce9c132727cf8ce077fba38fabcef92c3431b6ba SHA512 5d1b6ef089165b3325df35b31d33f7c994bbc302399bb47abf3138885f0dd7b04176114de8ffea6ee1ae26a53fc83be9016426714e547fd6405c454b918e39da
diff --git a/sys-libs/tdb/tdb-1.4.10.ebuild b/sys-libs/tdb/tdb-1.4.10.ebuild
new file mode 100644
index 000000000000..aaa8bb18ce55
--- /dev/null
+++ b/sys-libs/tdb/tdb-1.4.10.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="threads(+)"
+inherit waf-utils multilib-minimal python-single-r1
+
+DESCRIPTION="Simple database API"
+HOMEPAGE="https://tdb.samba.org/"
+SRC_URI="https://samba.org/ftp/tdb/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="python test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/libbsd[${MULTILIB_USEDEP}]
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/libcrypt
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ app-text/docbook-xml-dtd:4.2
+"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+src_prepare() {
+ default
+
+ python_fix_shebang .
+
+ if use test ; then
+ # TODO: Fix python tests to run w/ USE=python.
+ truncate -s0 python/tests/simple.py || die
+ fi
+
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ #MAKEOPTS+=" -j1"
+
+ local extra_opts=(
+ --libdir="${EPREFIX}/usr/$(get_libdir)"
+ --disable-dependency-tracking
+ --disable-warnings-as-errors
+ )
+
+ if ! multilib_is_native_abi || ! use python ; then
+ extra_opts+=( --disable-python )
+ fi
+
+ waf-utils_src_configure "${extra_opts[@]}"
+}
+
+multilib_src_compile() {
+ waf-utils_src_compile
+}
+
+multilib_src_test() {
+ # the default src_test runs 'make test' and 'make check', letting
+ # the tests fail occasionally (reason: unknown)
+ emake check
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+ use python && python_optimize
+}