summaryrefslogtreecommitdiff
path: root/sys-libs/readline/readline-8.2_p10.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/readline/readline-8.2_p10.ebuild')
-rw-r--r--sys-libs/readline/readline-8.2_p10.ebuild25
1 files changed, 19 insertions, 6 deletions
diff --git a/sys-libs/readline/readline-8.2_p10.ebuild b/sys-libs/readline/readline-8.2_p10.ebuild
index 26af570758a2..8445ab394a11 100644
--- a/sys-libs/readline/readline-8.2_p10.ebuild
+++ b/sys-libs/readline/readline-8.2_p10.ebuild
@@ -40,6 +40,7 @@ if [[ ${PV} == 9999 ]] ; then
inherit git-r3
elif is_release ; then
SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz"
+ SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/readline-8.1-rlfe-c99.patch.xz"
SRC_URI+=" verify-sig? ( mirror://gnu/${PN}/${MY_P}.tar.gz.sig )"
if [[ ${PLEVEL} -gt 0 ]] ; then
@@ -93,22 +94,34 @@ BDEPEND="virtual/pkgconfig
PATCHES=(
"${FILESDIR}"/${PN}-5.0-no_rpath.patch
- "${FILESDIR}"/${PN}-6.2-rlfe-tgoto.patch # bug #385091
"${FILESDIR}"/${PN}-7.0-headers.patch
"${FILESDIR}"/${PN}-8.0-headers.patch
+ "${WORKDIR}"/${PN}-8.1-rlfe-c99.patch
# TODO: rebase
#"${FILESDIR}"/${PN}-8.0-darwin-shlib-versioning.patch
)
src_unpack() {
- if [[ ${PV} == 9999 ]] ; then
+ local patch
+
+ if [[ ${PV} == 9999 ]]; then
git-r3_src_unpack
else
- # Needed because we don't want the patches being unpacked
- # (which emits annoying and useless error messages)
- verify-sig_src_unpack
- unpack ${MY_P}.tar.gz
+ if use verify-sig; then
+ verify-sig_verify_detached "${DISTDIR}/${MY_P}.tar.gz"{,.sig}
+
+ for patch in "${MY_PATCHES[@]}"; do
+ verify-sig_verify_detached "${patch}"{,.sig}
+ done
+ fi
+
+ unpack "${MY_P}.tar.gz"
+ unpack readline-8.1-rlfe-c99.patch.xz
+
+ #if [[ ${GENTOO_PATCH_VER} ]]; then
+ # unpack "${PN}-${GENTOO_PATCH_VER}-patches.tar.xz"
+ #fi
fi
}