summaryrefslogtreecommitdiff
path: root/sys-libs/readline/readline-8.2_p1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/readline/readline-8.2_p1.ebuild')
-rw-r--r--sys-libs/readline/readline-8.2_p1.ebuild21
1 files changed, 14 insertions, 7 deletions
diff --git a/sys-libs/readline/readline-8.2_p1.ebuild b/sys-libs/readline/readline-8.2_p1.ebuild
index b9f1a3da0874..29aa8e80be60 100644
--- a/sys-libs/readline/readline-8.2_p1.ebuild
+++ b/sys-libs/readline/readline-8.2_p1.ebuild
@@ -49,17 +49,24 @@ elif is_release ; then
patch_url=
my_patch_index=
+ upstream_url_base="mirror://gnu/bash"
+ mirror_url_base="ftp://ftp.cwru.edu/pub/bash"
+
for ((my_patch_index=1; my_patch_index <= ${PLEVEL} ; my_patch_index++)) ; do
- for url in mirror://gnu/${pn} ftp://ftp.cwru.edu/pub/bash ; do
- patch_url=$(printf "${url}/${PN}-$(ver_cut 1-2)-patches/${my_p}-%03d" ${my_patch_index})
- SRC_URI+=" ${patch_url}"
- SRC_URI+=" verify-sig? ( ${patch_url}.sig )"
- done
+ printf -v mangled_patch_ver ${my_p}-%03d ${my_patch_index}
+ patch_url="${upstream_url_base}/${MY_P}-patches/${mangled_patch_ver}"
+
+ SRC_URI+=" ${patch_url}"
+ SRC_URI+=" verify-sig? ( ${patch_url}.sig )"
+
+ # Add in the mirror URL too.
+ SRC_URI+=" ${patch_url/${upstream_url_base}/${mirror_url_base}}"
+ SRC_URI+=" verify-sig? ( ${patch_url/${upstream_url_base}/${mirror_url_base}} )"
- MY_PATCHES+=( "${DISTDIR}"/$(printf ${my_p}-%03d ${my_patch_index}) )
+ MY_PATCHES+=( "${DISTDIR}"/${mangled_patch_ver} )
done
- unset my_pn patch_url my_patch_index
+ unset my_p patch_url my_patch_index upstream_url_base mirror_url_base
fi
else
SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz ftp://ftp.cwru.edu/pub/bash/${MY_P}.tar.gz"