summaryrefslogtreecommitdiff
path: root/sys-libs/ncurses/ncurses-6.1_p20181020.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/ncurses/ncurses-6.1_p20181020.ebuild')
-rw-r--r--sys-libs/ncurses/ncurses-6.1_p20181020.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-libs/ncurses/ncurses-6.1_p20181020.ebuild b/sys-libs/ncurses/ncurses-6.1_p20181020.ebuild
index c96c376e5c8e..ba84afddf044 100644
--- a/sys-libs/ncurses/ncurses-6.1_p20181020.ebuild
+++ b/sys-libs/ncurses/ncurses-6.1_p20181020.ebuild
@@ -70,7 +70,7 @@ src_configure() {
# This comes up when cross-compiling, doing multilib builds, upgrading,
# or installing for the first time. Build a local copy of tic whenever
# the host version isn't available. #249363 #557598
- if ! ROOT=/ has_version "~sys-libs/${P}:0" ; then
+ if ! has_version -b "~sys-libs/${P}:0" ; then
local lbuildflags="-static"
# some toolchains don't quite support static linking
@@ -192,7 +192,7 @@ do_configure() {
src_compile() {
# See comments in src_configure.
- if ! ROOT=/ has_version "~sys-libs/${P}:0" ; then
+ if ! has_version -b "~sys-libs/${P}:0" ; then
BUILD_DIR="${WORKDIR}" \
do_compile cross -C progs tic
fi