summaryrefslogtreecommitdiff
path: root/sys-libs/mtdev/mtdev-1.1.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/mtdev/mtdev-1.1.7.ebuild')
-rw-r--r--sys-libs/mtdev/mtdev-1.1.7.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/sys-libs/mtdev/mtdev-1.1.7.ebuild b/sys-libs/mtdev/mtdev-1.1.7.ebuild
new file mode 100644
index 000000000000..fbfb9db211c0
--- /dev/null
+++ b/sys-libs/mtdev/mtdev-1.1.7.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Multitouch Protocol Translation Library"
+HOMEPAGE="https://bitmath.org/code/mtdev/"
+SRC_URI="https://bitmath.org/code/mtdev/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+DEPEND=">=sys-kernel/linux-headers-2.6.31"
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete
+}