summaryrefslogtreecommitdiff
path: root/sys-libs/libseccomp/libseccomp-2.5.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/libseccomp/libseccomp-2.5.5-r1.ebuild')
-rw-r--r--sys-libs/libseccomp/libseccomp-2.5.5-r1.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/sys-libs/libseccomp/libseccomp-2.5.5-r1.ebuild b/sys-libs/libseccomp/libseccomp-2.5.5-r1.ebuild
index 347a6274d5f7..ecedd688b53f 100644
--- a/sys-libs/libseccomp/libseccomp-2.5.5-r1.ebuild
+++ b/sys-libs/libseccomp/libseccomp-2.5.5-r1.ebuild
@@ -16,10 +16,14 @@ HOMEPAGE="https://github.com/seccomp/libseccomp"
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/seccomp/libseccomp.git"
PRERELEASE="2.6.0"
+ AUTOTOOLS_AUTO_DEPEND=yes
inherit autotools git-r3
else
+ AUTOTOOLS_AUTO_DEPEND=no
+ inherit autotools
SRC_URI="https://github.com/seccomp/libseccomp/releases/download/v${PV}/${P}.tar.gz
- experimental-loong? ( https://dev.gentoo.org/~xen0n/distfiles/${PN}-2.5.5-loongarch64-20231204.patch.xz )"
+ experimental-loong? ( https://github.com/matoro/libseccomp/compare/v${PV}..loongarch-r1.patch
+ -> ${P}-loongarch-r1.patch )"
KEYWORDS="-* amd64 arm arm64 ~hppa ~loong ~mips ppc ppc64 ~riscv ~s390 x86 ~amd64-linux ~x86-linux"
fi
@@ -39,6 +43,7 @@ RDEPEND="${DEPEND}"
BDEPEND="
${DEPEND}
dev-util/gperf
+ experimental-loong? ( ${AUTOTOOLS_DEPEND} )
python? (
${DISTUTILS_DEPS}
dev-python/cython[${PYTHON_USEDEP}]
@@ -54,11 +59,15 @@ PATCHES=(
src_prepare() {
if use experimental-loong; then
- PATCHES+=( "${WORKDIR}/${PN}-2.5.5-loongarch64-20231204.patch" )
+ PATCHES+=( "${DISTDIR}/${P}-loongarch-r1.patch" )
fi
default
+ if [[ ${PV} == *9999 ]] ; then
+ sed -i -e "s/0.0.0/${PRERELEASE}/" configure.ac || die
+ fi
+
if use experimental-loong; then
# touch generated files to avoid activating maintainer mode
# remove when loong-fix-build.patch is no longer necessary
@@ -66,9 +75,8 @@ src_prepare() {
find . -name Makefile.in -exec touch {} + || die
fi
- if [[ ${PV} == *9999 ]] ; then
- sed -i -e "s/0.0.0/${PRERELEASE}/" configure.ac || die
-
+ if [[ ${PV} == *9999 ]] || use experimental-loong; then
+ rm -f "include/seccomp.h" || die
eautoreconf
fi
}