summaryrefslogtreecommitdiff
path: root/sys-libs/libseccomp/libseccomp-2.5.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/libseccomp/libseccomp-2.5.1.ebuild')
-rw-r--r--sys-libs/libseccomp/libseccomp-2.5.1.ebuild16
1 files changed, 6 insertions, 10 deletions
diff --git a/sys-libs/libseccomp/libseccomp-2.5.1.ebuild b/sys-libs/libseccomp/libseccomp-2.5.1.ebuild
index df4feff97243..b68cd3835b8d 100644
--- a/sys-libs/libseccomp/libseccomp-2.5.1.ebuild
+++ b/sys-libs/libseccomp/libseccomp-2.5.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,7 +17,7 @@ if [[ ${PV} == *9999 ]] ; then
inherit autotools git-r3
else
SRC_URI="https://github.com/seccomp/libseccomp/releases/download/v${PV}/${P}.tar.gz"
- KEYWORDS="-* ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~x86 ~amd64-linux ~x86-linux"
+ KEYWORDS="-* amd64 arm arm64 hppa ~mips ppc ppc64 ~riscv ~s390 x86 ~amd64-linux ~x86-linux"
fi
LICENSE="LGPL-2.1"
@@ -30,16 +30,12 @@ REQUIRED_USE="
${PYTHON_REQUIRED_USE}
)"
-BDEPEND="
+DEPEND="python? ( ${PYTHON_DEPS} )"
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}
dev-util/gperf
- python? (
- ${PYTHON_DEPS}
- dev-python/cython[${PYTHON_USEDEP}]
- )
+ python? ( dev-python/cython[${PYTHON_USEDEP}] )
"
-DEPEND="${BDEPEND}"
-RDEPEND="${DEPEND}"
-
# We need newer kernel headers; we don't keep strict control of the exact
# version here, just be safe and pull in the latest stable ones. #551248
DEPEND="${DEPEND} >=sys-kernel/linux-headers-4.3"