summaryrefslogtreecommitdiff
path: root/sys-libs/libcxx/libcxx-11.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/libcxx/libcxx-11.0.0.ebuild')
-rw-r--r--sys-libs/libcxx/libcxx-11.0.0.ebuild9
1 files changed, 1 insertions, 8 deletions
diff --git a/sys-libs/libcxx/libcxx-11.0.0.ebuild b/sys-libs/libcxx/libcxx-11.0.0.ebuild
index f63adc4cf51c..8f948316ac8d 100644
--- a/sys-libs/libcxx/libcxx-11.0.0.ebuild
+++ b/sys-libs/libcxx/libcxx-11.0.0.ebuild
@@ -10,6 +10,7 @@ inherit cmake-multilib llvm llvm.org python-any-r1 toolchain-funcs
DESCRIPTION="New implementation of the C++ standard library, targeting C++11"
HOMEPAGE="https://libcxx.llvm.org/"
LLVM_COMPONENTS=( libcxx{,abi} llvm/{cmake/modules,utils/llvm-lit} )
+LLVM_PATCHSET=11.0.0-1
llvm.org_set_globals
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
@@ -57,14 +58,6 @@ pkg_setup() {
fi
}
-src_prepare() {
- # Add link flag "-Wl,-z,defs" to avoid underlinking; this is needed in a
- # out-of-tree build.
- eapply "${FILESDIR}/${PN}-3.9-cmake-link-flags.patch"
-
- llvm.org_src_prepare
-}
-
test_compiler() {
$(tc-getCXX) ${CXXFLAGS} ${LDFLAGS} "${@}" -o /dev/null -x c++ - \
<<<'int main() { return 0; }' &>/dev/null