summaryrefslogtreecommitdiff
path: root/sys-libs/libcap-ng/files/libcap-ng-0.8.5-python.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/libcap-ng/files/libcap-ng-0.8.5-python.patch')
-rw-r--r--sys-libs/libcap-ng/files/libcap-ng-0.8.5-python.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/sys-libs/libcap-ng/files/libcap-ng-0.8.5-python.patch b/sys-libs/libcap-ng/files/libcap-ng-0.8.5-python.patch
new file mode 100644
index 000000000000..ddad5ff49d7a
--- /dev/null
+++ b/sys-libs/libcap-ng/files/libcap-ng-0.8.5-python.patch
@@ -0,0 +1,23 @@
+https://github.com/stevegrubb/libcap-ng/commit/1fe7c1cfeea00ba4eb903fbb39b74361594d4835
+
+From 1fe7c1cfeea00ba4eb903fbb39b74361594d4835 Mon Sep 17 00:00:00 2001
+From: Jan Palus <jpalus@fastmail.com>
+Date: Wed, 10 Apr 2024 21:30:51 +0200
+Subject: [PATCH] Fix python path when invoking py-compile (#54)
+
+48eebb2 replaced custom PYTHON3 variable with PYTHON by using standard
+AM_PATH_PYTHON macro. Makefile however still referred to old one.
+There's no need to set PYTHON explicitly anymore so drop it.
+
+Fixes #53
+--- a/bindings/python3/Makefile.am
++++ b/bindings/python3/Makefile.am
+@@ -27,7 +27,6 @@ AM_CPPFLAGS = -I. -I$(top_builddir) $(PYTHON3_INCLUDES)
+ LIBS = ${top_builddir}/src/libcap-ng.la
+ SWIG_FLAGS = -python
+ SWIG_INCLUDES = ${AM_CPPFLAGS}
+-PYTHON = $(PYTHON3)
+ pyexec_PYTHON = capng.py
+ pyexec_LTLIBRARIES = _capng.la
+ pyexec_SOLIBRARIES = _capng.so
+