summaryrefslogtreecommitdiff
path: root/sys-libs/kpmcore/kpmcore-24.02.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/kpmcore/kpmcore-24.02.2.ebuild')
-rw-r--r--sys-libs/kpmcore/kpmcore-24.02.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-libs/kpmcore/kpmcore-24.02.2.ebuild b/sys-libs/kpmcore/kpmcore-24.02.2.ebuild
new file mode 100644
index 000000000000..981859e0e0f5
--- /dev/null
+++ b/sys-libs/kpmcore/kpmcore-24.02.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_NONGUI="true"
+KFMIN=6.0.0
+QTMIN=6.6.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Library for managing partitions"
+HOMEPAGE="https://apps.kde.org/partitionmanager/"
+
+LICENSE="GPL-3"
+SLOT="6/10"
+KEYWORDS="~amd64"
+IUSE=""
+
+# bug 689468, tests need polkit etc.
+RESTRICT="test"
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,widgets]
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+ >=sys-apps/util-linux-2.33.2
+ >=sys-auth/polkit-qt-0.175.0[qt6]
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"