summaryrefslogtreecommitdiff
path: root/sys-libs/glibc/glibc-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/glibc/glibc-9999.ebuild')
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index f82a00f91c2f..5a0caff2e597 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -512,8 +512,12 @@ setup_flags() {
# should not be a problem, but for glibc it matters as it is
# dealing with CET in ld.so. So if CET is supposed to be
# disabled for glibc, be explicit about it.
- if (use amd64 || use x86) && ! use cet; then
- append-flags '-fcf-protection=none'
+ if ! use cet; then
+ if use amd64 || use x86; then
+ append-flags '-fcf-protection=none'
+ elif use arm64; then
+ append-flags '-mbranch-protection=none'
+ fi
fi
}