summaryrefslogtreecommitdiff
path: root/sys-libs/glibc/glibc-2.39-r9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/glibc/glibc-2.39-r9.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.39-r9.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/sys-libs/glibc/glibc-2.39-r9.ebuild b/sys-libs/glibc/glibc-2.39-r9.ebuild
index e6650fa8057d..da579ed2837b 100644
--- a/sys-libs/glibc/glibc-2.39-r9.ebuild
+++ b/sys-libs/glibc/glibc-2.39-r9.ebuild
@@ -515,11 +515,14 @@ setup_flags() {
# dealing with CET in ld.so. So if CET is supposed to be
# disabled for glibc, be explicit about it.
if ! use cet; then
- if use amd64 || use x86; then
- append-flags '-fcf-protection=none'
- elif use arm64; then
- append-flags '-mbranch-protection=none'
- fi
+ case ${ABI}-${CTARGET} in
+ amd64-x86_64-*|x32-x86_64-*-*-gnux32)
+ append-flags '-fcf-protection=none'
+ ;;
+ arm64-aarch64*)
+ append-flags '-mbranch-protection=none'
+ ;;
+ esac
fi
}