summaryrefslogtreecommitdiff
path: root/sys-libs/glibc/glibc-2.38-r11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/glibc/glibc-2.38-r11.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.38-r11.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/sys-libs/glibc/glibc-2.38-r11.ebuild b/sys-libs/glibc/glibc-2.38-r11.ebuild
index 8da751b46e7c..93f0999d1d03 100644
--- a/sys-libs/glibc/glibc-2.38-r11.ebuild
+++ b/sys-libs/glibc/glibc-2.38-r11.ebuild
@@ -576,10 +576,12 @@ setup_env() {
# Reset CC and CXX to the value at start of emerge
export CC=${glibc__ORIG_CC:-${CC:-$(tc-getCC ${CTARGET})}}
export CXX=${glibc__ORIG_CXX:-${CXX:-$(tc-getCXX ${CTARGET})}}
+ export CPP=${glibc__ORIG_CPP:-${CPP:-$(tc-getCPP ${CTARGET})}}
# and make sure glibc__ORIG_CC and glibc__ORIG_CXX is defined now.
export glibc__ORIG_CC=${CC}
export glibc__ORIG_CXX=${CXX}
+ export glibc__ORIG_CPP=${CPP}
if tc-is-clang && ! use custom-cflags && ! is_crosscompile ; then
export glibc__force_gcc=yes
@@ -606,6 +608,7 @@ setup_env() {
export CC="${current_gcc_path}/gcc"
export CPP="${current_gcc_path}/cpp"
export CXX="${current_gcc_path}/g++"
+ export CPP="$(tc-getCPP ${CTARGET})"
export LD="${current_binutils_path}/ld.bfd"
export AR="${current_binutils_path}/ar"
export AS="${current_binutils_path}/as"
@@ -644,6 +647,7 @@ setup_env() {
# acts on CC?)
export glibc__GLIBC_CC=${CC}
export glibc__GLIBC_CXX=${CXX}
+ export glibc__GLIBC_CPP=${CPP}
export glibc__abi_CFLAGS="$(get_abi_CFLAGS)"
@@ -659,6 +663,8 @@ setup_env() {
# Some of the tests are written in C++, so we need to force our multlib abis in, bug 623548
export CXX="${glibc__GLIBC_CXX} ${glibc__abi_CFLAGS} ${CFLAGS}"
+ export CPP="${glibc__GLIBC_CPP} ${glibc__abi_CFLAGS}"
+
if is_crosscompile; then
# Assume worst-case bootstrap: glibc is built for the first time
# with ${CTARGET}-g++ not available yet. We avoid