summaryrefslogtreecommitdiff
path: root/sys-libs/glibc/glibc-2.33-r14.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/glibc/glibc-2.33-r14.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.33-r14.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/sys-libs/glibc/glibc-2.33-r14.ebuild b/sys-libs/glibc/glibc-2.33-r14.ebuild
index a9012e350120..9119534902f5 100644
--- a/sys-libs/glibc/glibc-2.33-r14.ebuild
+++ b/sys-libs/glibc/glibc-2.33-r14.ebuild
@@ -733,7 +733,7 @@ sanity_prechecks() {
# we test for...
if ! is_crosscompile ; then
if use amd64 && use multilib && [[ ${MERGE_TYPE} != "binary" ]] ; then
- ebegin "Checking that IA32 emulation is enabled in the running kernel"
+ ebegin "Checking if the system can execute 32-bit binaries"
echo 'int main(){return 0;}' > "${T}/check-ia32-emulation.c"
local STAT
if "${CC-${CHOST}-gcc}" ${CFLAGS_x86} "${T}/check-ia32-emulation.c" -o "${T}/check-ia32-emulation.elf32"; then
@@ -747,7 +747,11 @@ sanity_prechecks() {
fi
rm -f "${T}/check-ia32-emulation.elf32"
eend $STAT
- [[ $STAT -eq 0 ]] || die "CONFIG_IA32_EMULATION must be enabled in the kernel to compile a multilib glibc."
+ if [[ $STAT -ne 0 ]]; then
+ eerror "Ensure that CONFIG_IA32_EMULATION is enabled in the kernel."
+ eerror "Seek support otherwise."
+ die "Unable to execute 32-bit binaries"
+ fi
fi
fi