summaryrefslogtreecommitdiff
path: root/sys-libs/glibc/glibc-2.32-r8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/glibc/glibc-2.32-r8.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.32-r8.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/sys-libs/glibc/glibc-2.32-r8.ebuild b/sys-libs/glibc/glibc-2.32-r8.ebuild
index 977997ef0840..65aa84f364aa 100644
--- a/sys-libs/glibc/glibc-2.32-r8.ebuild
+++ b/sys-libs/glibc/glibc-2.32-r8.ebuild
@@ -666,7 +666,7 @@ sanity_prechecks() {
# we test for...
if ! is_crosscompile ; then
if use amd64 && use multilib && [[ ${MERGE_TYPE} != "binary" ]] ; then
- ebegin "Checking that IA32 emulation is enabled in the running kernel"
+ ebegin "Checking if the system can execute 32-bit binaries"
echo 'int main(){return 0;}' > "${T}/check-ia32-emulation.c"
local STAT
if "${CC-${CHOST}-gcc}" ${CFLAGS_x86} "${T}/check-ia32-emulation.c" -o "${T}/check-ia32-emulation.elf32"; then
@@ -680,7 +680,11 @@ sanity_prechecks() {
fi
rm -f "${T}/check-ia32-emulation.elf32"
eend $STAT
- [[ $STAT -eq 0 ]] || die "CONFIG_IA32_EMULATION must be enabled in the kernel to compile a multilib glibc."
+ if [[ $STAT -ne 0 ]]; then
+ eerror "Ensure that CONFIG_IA32_EMULATION is enabled in the kernel."
+ eerror "Seek support otherwise."
+ die "Unable to execute 32-bit binaries"
+ fi
fi
fi