summaryrefslogtreecommitdiff
path: root/sys-libs/glibc/glibc-2.30-r8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/glibc/glibc-2.30-r8.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.30-r8.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/sys-libs/glibc/glibc-2.30-r8.ebuild b/sys-libs/glibc/glibc-2.30-r8.ebuild
index aea0098e69f7..0421d5e61db1 100644
--- a/sys-libs/glibc/glibc-2.30-r8.ebuild
+++ b/sys-libs/glibc/glibc-2.30-r8.ebuild
@@ -305,6 +305,12 @@ setup_target_flags() {
einfo "Auto adding -march=${t} to CFLAGS_x86 #185404 (ABI=${ABI})"
fi
;;
+ ia64)
+ # Workaround GPREL22 overflow by slightly pessimizing global
+ # references to go via 64-bit relocations instead of 22-bit ones.
+ # This allows building glibc on ia64 without an overflow: #723268
+ append-flags -fcommon
+ ;;
mips)
# The mips abi cannot support the GNU style hashes. #233233
filter-ldflags -Wl,--hash-style=gnu -Wl,--hash-style=both