summaryrefslogtreecommitdiff
path: root/sys-libs/glibc/glibc-2.28-r5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/glibc/glibc-2.28-r5.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.28-r5.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/sys-libs/glibc/glibc-2.28-r5.ebuild b/sys-libs/glibc/glibc-2.28-r5.ebuild
index 827b432313ee..9087d26caafa 100644
--- a/sys-libs/glibc/glibc-2.28-r5.ebuild
+++ b/sys-libs/glibc/glibc-2.28-r5.ebuild
@@ -799,6 +799,11 @@ glibc_do_configure() {
local myconf=()
case ${CTARGET} in
+ m68k*)
+ # setjmp() is not compatible with stack protection:
+ # https://sourceware.org/PR24202
+ myconf+=( --enable-stack-protector=no )
+ ;;
powerpc-*)
# Currently gcc on powerpc32 generates invalid code for
# __builtin_return_address(0) calls. Normally programs