summaryrefslogtreecommitdiff
path: root/sys-libs/db/db-5.3.28-r8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/db/db-5.3.28-r8.ebuild')
-rw-r--r--sys-libs/db/db-5.3.28-r8.ebuild42
1 files changed, 7 insertions, 35 deletions
diff --git a/sys-libs/db/db-5.3.28-r8.ebuild b/sys-libs/db/db-5.3.28-r8.ebuild
index 91d4a786cf4c..c7f5d0f6d288 100644
--- a/sys-libs/db/db-5.3.28-r8.ebuild
+++ b/sys-libs/db/db-5.3.28-r8.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools db flag-o-matic java-pkg-opt-2 multilib multilib-minimal toolchain-funcs
+inherit autotools db flag-o-matic multilib multilib-minimal toolchain-funcs
#Number of official patches
#PATCHNO=`echo ${PV}|sed -e "s,\(.*_p\)\([0-9]*\),\2,"`
@@ -30,29 +30,20 @@ done
LICENSE="Sleepycat"
SLOT="$(ver_cut 1-2)"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="doc java cxx tcl test"
+IUSE="doc cxx tcl test"
REQUIRED_USE="test? ( tcl )"
# the entire testsuite needs the TCL functionality
DEPEND="tcl? ( >=dev-lang/tcl-8.5.15-r1:0=[${MULTILIB_USEDEP}] )
- test? ( >=dev-lang/tcl-8.5.15-r1:0=[${MULTILIB_USEDEP}] )
- java? ( >=virtual/jdk-1.7 )"
-RDEPEND="tcl? ( >=dev-lang/tcl-8.5.15-r1:0=[${MULTILIB_USEDEP}] )
- java? ( >=virtual/jre-1.7 )"
+ test? ( >=dev-lang/tcl-8.5.15-r1:0=[${MULTILIB_USEDEP}] )"
+RDEPEND="tcl? ( >=dev-lang/tcl-8.5.15-r1:0=[${MULTILIB_USEDEP}] )"
MULTILIB_WRAPPED_HEADERS=(
/usr/include/db${SLOT}/db.h
)
PATCHES=(
- # bug #510506
- "${FILESDIR}"/${PN}-4.8.24-java-manifest-location.patch
-
- # use the includes from the prefix
- "${FILESDIR}"/${PN}-4.6-jni-check-prefix-first.patch
- "${FILESDIR}"/${PN}-4.2-listen-to-java-options.patch
-
# sqlite configure call has an extra leading ..
# upstreamed:5.2.36, missing in 5.3.x
"${FILESDIR}"/${PN}-5.2.28-sqlite-configure-path.patch
@@ -83,12 +74,6 @@ src_prepare() {
-e "/^DB_RELEASE_DATE=/s~=.*~='${REAL_DB_RELEASE_DATE}'~g" \
-i dist/RELEASE || die
- # Include the SLOT for Java JAR files
- # This supersedes the unused jarlocation patches.
- sed -r \
- -e '/jarfile=.*\.jar$/s,(.jar$),-$(LIBVERSION)\1,g' \
- -i dist/Makefile.in || die
-
cd dist || die
rm aclocal/libtool.m4 || die
sed \
@@ -98,9 +83,9 @@ src_prepare() {
-e '/^AC_PATH_TOOL/s/ sh, none/ bash, none/' \
-i aclocal/programs.m4 || die
- AT_M4DIR="aclocal aclocal_java" eautoreconf
+ AT_M4DIR="aclocal" eautoreconf
- # Upstream sucks - they do autoconf and THEN replace the version variables.
+ # They do autoconf and THEN replace the version variables :(
. ./RELEASE
local v ev
for v in \
@@ -133,10 +118,10 @@ multilib_src_configure() {
--disable-sql_codegen
--disable-sql_compat
--disable-static
+ --disable-java
$([[ ${ABI} == amd64 ]] && echo --with-mutex=x86/gcc-assembly)
$(use_enable cxx)
$(use_enable cxx stl)
- $(multilib_native_use_enable java)
$(use_enable test)
)
@@ -153,13 +138,6 @@ multilib_src_configure() {
# mumbo jumbo.
append-ldflags -Wl,--default-symver
- if multilib_is_native_abi && use java ; then
- myconf+=(
- --with-java-prefix="${JAVA_HOME}"
- --with-javac-flags="$(java-pkg_javac-args)"
- )
- fi
-
# Bug #270851: test needs TCL support
if use tcl || use test ; then
myconf+=(
@@ -189,12 +167,6 @@ multilib_src_install() {
db_src_install_headerslot
db_src_install_usrlibcleanup
-
- if multilib_is_native_abi && use java; then
- java-pkg_regso "${ED}"/usr/"$(get_libdir)"/libdb_java*.so
- java-pkg_dojar "${ED}"/usr/"$(get_libdir)"/*.jar
- rm -f "${ED}"/usr/"$(get_libdir)"/*.jar
- fi
}
multilib_src_install_all() {