summaryrefslogtreecommitdiff
path: root/sys-libs/db/db-4.8.30-r6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/db/db-4.8.30-r6.ebuild')
-rw-r--r--sys-libs/db/db-4.8.30-r6.ebuild41
1 files changed, 7 insertions, 34 deletions
diff --git a/sys-libs/db/db-4.8.30-r6.ebuild b/sys-libs/db/db-4.8.30-r6.ebuild
index 3bc178287279..ca3d63339448 100644
--- a/sys-libs/db/db-4.8.30-r6.ebuild
+++ b/sys-libs/db/db-4.8.30-r6.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools db flag-o-matic java-pkg-opt-2 multilib multilib-minimal toolchain-funcs
+inherit autotools db flag-o-matic multilib multilib-minimal toolchain-funcs
#Number of official patches
#PATCHNO=`echo ${PV}|sed -e "s,\(.*_p\)\([0-9]*\),\2,"`
@@ -30,25 +30,18 @@ done
LICENSE="Sleepycat"
SLOT="$(ver_cut 1-2)"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86"
-IUSE="doc java cxx tcl test"
+IUSE="doc cxx tcl test"
REQUIRED_USE="test? ( tcl )"
# the entire testsuite needs the TCL functionality
DEPEND="tcl? ( >=dev-lang/tcl-8.5.15-r1:0=[${MULTILIB_USEDEP}] )
- test? ( >=dev-lang/tcl-8.5.15-r1:0=[${MULTILIB_USEDEP}] )
- java? ( >=virtual/jdk-1.8 )"
-RDEPEND="tcl? ( >=dev-lang/tcl-8.5.15-r1:0=[${MULTILIB_USEDEP}] )
- java? ( >=virtual/jre-1.8 )"
+ test? ( >=dev-lang/tcl-8.5.15-r1:0=[${MULTILIB_USEDEP}] )"
+RDEPEND="tcl? ( >=dev-lang/tcl-8.5.15-r1:0=[${MULTILIB_USEDEP}] )"
PATCHES=(
"${FILESDIR}"/${PN}-4.8-libtool.patch
- "${FILESDIR}"/${PN}-4.8.24-java-manifest-location.patch
"${FILESDIR}"/${PN}-4.8.30-rename-atomic-compare-exchange.patch
-
- # use the includes from the prefix
- "${FILESDIR}"/${PN}-4.6-jni-check-prefix-first.patch
- "${FILESDIR}"/${PN}-4.2-listen-to-java-options.patch
)
src_prepare() {
@@ -63,12 +56,6 @@ src_prepare() {
sed -e "/^DB_RELEASE_DATE=/s/%B %e, %Y/%Y-%m-%d/" -i dist/RELEASE \
|| die
- # Include the SLOT for Java JAR files
- # This supersedes the unused jarlocation patches.
- sed -r \
- -e '/jarfile=.*\.jar$/s,(.jar$),-$(LIBVERSION)\1,g' \
- -i dist/Makefile.in || die
-
cd dist || die
rm aclocal/libtool.m4 || die
sed \
@@ -78,9 +65,9 @@ src_prepare() {
-e '/^AC_PATH_TOOL/s/ sh, none/ bash, none/' \
-i aclocal/programs.m4 || die
- AT_M4DIR="aclocal aclocal_java" eautoreconf
+ AT_M4DIR="aclocal" eautoreconf
- # Upstream sucks - they do autoconf and THEN replace the version variables.
+ # They do autoconf and THEN replace the version variables :(
. ./RELEASE
sed \
-e "s/__EDIT_DB_VERSION_MAJOR__/$DB_VERSION_MAJOR/g" \
@@ -98,10 +85,10 @@ multilib_src_configure() {
--enable-o_direct
--without-uniquename
--disable-static
+ --disable-java
$([[ ${ABI} == amd64 ]] && echo --with-mutex=x86/gcc-assembly)
$(use_enable cxx)
$(use_enable cxx stl)
- $(multilib_native_use_enable java)
$(use_enable test)
)
@@ -118,14 +105,6 @@ multilib_src_configure() {
# mumbo jumbo.
append-ldflags -Wl,--default-symver
- # use `set` here since the java opts will contain whitespace
- if multilib_is_native_abi && use java ; then
- myconf+=(
- --with-java-prefix="${JAVA_HOME}"
- --with-javac-flags="$(java-pkg_javac-args)"
- )
- fi
-
# Bug #270851: test needs TCL support
if use tcl || use test ; then
myconf+=(
@@ -161,12 +140,6 @@ multilib_src_install() {
db_src_install_headerslot
db_src_install_usrlibcleanup
-
- if multilib_is_native_abi && use java; then
- java-pkg_regso "${ED}"/usr/"$(get_libdir)"/libdb_java*.so
- java-pkg_dojar "${ED}"/usr/"$(get_libdir)"/*.jar
- rm -f "${ED}"/usr/"$(get_libdir)"/*.jar
- fi
}
multilib_src_install_all() {