summaryrefslogtreecommitdiff
path: root/sys-libs/compiler-rt/compiler-rt-9.0.1.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/compiler-rt/compiler-rt-9.0.1.9999.ebuild')
-rw-r--r--sys-libs/compiler-rt/compiler-rt-9.0.1.9999.ebuild12
1 files changed, 3 insertions, 9 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-9.0.1.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-9.0.1.9999.ebuild
index 88bfd8aa0ad2..1c0ee0530aff 100644
--- a/sys-libs/compiler-rt/compiler-rt-9.0.1.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-9.0.1.9999.ebuild
@@ -3,20 +3,14 @@
EAPI=7
-: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
-# (needed due to CMAKE_BUILD_TYPE != Gentoo)
-CMAKE_MIN_VERSION=3.7.0-r1
PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-
-inherit cmake-utils flag-o-matic git-r3 llvm multiprocessing \
+inherit cmake-utils flag-o-matic llvm llvm.org multiprocessing \
python-any-r1 toolchain-funcs
DESCRIPTION="Compiler runtime library for clang (built-in part)"
HOMEPAGE="https://llvm.org/"
-SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/compiler-rt.git
- https://github.com/llvm-mirror/compiler-rt.git"
-EGIT_BRANCH="release_90"
+LLVM_COMPONENTS=( compiler-rt )
+llvm.org_set_globals
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="$(ver_cut 1-3)"