summaryrefslogtreecommitdiff
path: root/sys-libs/compiler-rt/compiler-rt-5.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/compiler-rt/compiler-rt-5.0.1.ebuild')
-rw-r--r--sys-libs/compiler-rt/compiler-rt-5.0.1.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-5.0.1.ebuild b/sys-libs/compiler-rt/compiler-rt-5.0.1.ebuild
index 9b135a41b328..020ddaac8475 100644
--- a/sys-libs/compiler-rt/compiler-rt-5.0.1.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-5.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,7 +16,7 @@ SRC_URI="https://releases.llvm.org/${PV/_//}/${P/_/}.src.tar.xz"
LICENSE="|| ( UoI-NCSA MIT )"
SLOT="${PV%_*}"
-KEYWORDS="~amd64 ~arm64 ~x86"
+KEYWORDS="~amd64 ~arm64 ~x86 ~ppc-macos ~x64-macos ~x86-macos"
IUSE="+clang test"
LLVM_SLOT=${SLOT%%.*}
@@ -77,6 +77,13 @@ src_configure() {
-DCOMPILER_RT_BUILD_XRAY=OFF
)
+ if use prefix && [[ "${CHOST}" == *-darwin* ]] ; then
+ mycmakeargs+=(
+ # disable use of SDK for the system itself
+ -DDARWIN_macosx_CACHED_SYSROOT=/
+ )
+ fi
+
if use test; then
mycmakeargs+=(
-DLIT_COMMAND="${EPREFIX}/usr/bin/lit"