summaryrefslogtreecommitdiff
path: root/sys-libs/compiler-rt/compiler-rt-15.0.0.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/compiler-rt/compiler-rt-15.0.0.9999.ebuild')
-rw-r--r--sys-libs/compiler-rt/compiler-rt-15.0.0.9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-15.0.0.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-15.0.0.9999.ebuild
index 1c847a474a08..1a7cc5f2b724 100644
--- a/sys-libs/compiler-rt/compiler-rt-15.0.0.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-15.0.0.9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
inherit cmake flag-o-matic llvm llvm.org python-any-r1 toolchain-funcs
@@ -18,17 +18,19 @@ RESTRICT="!test? ( test ) !clang? ( test )"
CLANG_SLOT=${SLOT%%.*}
# llvm-6 for new lit options
DEPEND="
- >=sys-devel/llvm-6"
+ >=sys-devel/llvm-6
+"
BDEPEND="
>=dev-util/cmake-3.16
clang? ( sys-devel/clang )
test? (
- $(python_gen_any_dep ">=dev-python/lit-9.0.1[\${PYTHON_USEDEP}]")
+ $(python_gen_any_dep ">=dev-python/lit-15[\${PYTHON_USEDEP}]")
=sys-devel/clang-${PV%_*}*:${CLANG_SLOT}
)
!test? (
${PYTHON_DEPS}
- )"
+ )
+"
LLVM_COMPONENTS=( compiler-rt cmake )
LLVM_PATCHSET=9999-1