summaryrefslogtreecommitdiff
path: root/sys-kernel/linux-headers/linux-headers-5.15-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/linux-headers/linux-headers-5.15-r3.ebuild')
-rw-r--r--sys-kernel/linux-headers/linux-headers-5.15-r3.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/sys-kernel/linux-headers/linux-headers-5.15-r3.ebuild b/sys-kernel/linux-headers/linux-headers-5.15-r3.ebuild
index 6541482454d5..9d2ebae3daee 100644
--- a/sys-kernel/linux-headers/linux-headers-5.15-r3.ebuild
+++ b/sys-kernel/linux-headers/linux-headers-5.15-r3.ebuild
@@ -5,7 +5,7 @@ EAPI=7
ETYPE="headers"
H_SUPPORTEDARCH="alpha amd64 arc arm arm64 avr32 cris frv hexagon hppa ia64 m68k metag microblaze mips mn10300 nios2 openrisc ppc ppc64 riscv s390 score sh sparc x86 xtensa"
-inherit kernel-2 toolchain-funcs
+inherit kernel-2
detect_version
PATCH_PV=${PV} # to ease testing new versions against not existing patches
@@ -17,7 +17,8 @@ S="${WORKDIR}/linux-${PV}"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-BDEPEND="app-arch/xz-utils
+BDEPEND="
+ app-arch/xz-utils
dev-lang/perl"
# bug #816762
@@ -31,11 +32,11 @@ src_unpack() {
}
src_prepare() {
- if use elibc_musl ; then
- # TODO: May need forward porting to newer versions
- eapply "${FILESDIR}"/${PN}-5.10-Use-stddefs.h-instead-of-compiler.h.patch
- eapply "${FILESDIR}"/${PN}-5.15-remove-inclusion-sysinfo.h.patch
- fi
+ # TODO: May need forward porting to newer versions
+ use elibc_musl && PATCHES+=(
+ "${FILESDIR}"/${PN}-5.10-Use-stddefs.h-instead-of-compiler.h.patch
+ "${FILESDIR}"/${PN}-5.15-remove-inclusion-sysinfo.h.patch
+ )
# avoid kernel-2_src_prepare
default
@@ -49,4 +50,6 @@ src_install() {
kernel-2_src_install
find "${ED}" \( -name '.install' -o -name '*.cmd' \) -delete || die
+ # delete empty directories
+ find "${ED}" -empty -type d -delete || die
}