summaryrefslogtreecommitdiff
path: root/sys-kernel/linux-headers/linux-headers-4.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/linux-headers/linux-headers-4.4.ebuild')
-rw-r--r--sys-kernel/linux-headers/linux-headers-4.4.ebuild28
1 files changed, 10 insertions, 18 deletions
diff --git a/sys-kernel/linux-headers/linux-headers-4.4.ebuild b/sys-kernel/linux-headers/linux-headers-4.4.ebuild
index 7179ff17febc..0bf7828fca73 100644
--- a/sys-kernel/linux-headers/linux-headers-4.4.ebuild
+++ b/sys-kernel/linux-headers/linux-headers-4.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,7 +12,7 @@ PATCH_VER="1"
SRC_URI="mirror://gentoo/gentoo-headers-base-${PV}.tar.xz
${PATCH_VER:+mirror://gentoo/gentoo-headers-${PV}-${PATCH_VER}.tar.xz}"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
DEPEND="app-arch/xz-utils
dev-lang/perl"
@@ -30,28 +30,20 @@ src_prepare() {
[[ -n ${PATCH_VER} ]] && eapply "${WORKDIR}/${PV}"/*.patch
}
-src_install() {
- kernel-2_src_install
-
- # hrm, build system sucks
- find "${ED}" '(' -name '.install' -o -name '*.cmd' ')' -delete
- find "${ED}" -depth -type d -delete 2>/dev/null
-}
-
src_test() {
- # Make sure no uapi/ include paths are used by accident.
- egrep -r \
- -e '# *include.*["<]uapi/' \
- "${D}" && die "#include uapi/xxx detected"
-
einfo "Possible unescaped attribute/type usage"
egrep -r \
-e '(^|[[:space:](])(asm|volatile|inline)[[:space:](]' \
-e '\<([us](8|16|32|64))\>' \
.
- einfo "Missing linux/types.h include"
- egrep -l -r -e '__[us](8|16|32|64)' "${ED}" | xargs grep -L linux/types.h
-
emake ARCH=$(tc-arch-kernel) headers_check
}
+
+src_install() {
+ kernel-2_src_install
+
+ # hrm, build system sucks
+ find "${ED}" '(' -name '.install' -o -name '*.cmd' ')' -delete
+ find "${ED}" -depth -type d -delete 2>/dev/null
+}