summaryrefslogtreecommitdiff
path: root/sys-kernel/linux-firmware/linux-firmware-20240709-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/linux-firmware/linux-firmware-20240709-r1.ebuild')
-rw-r--r--sys-kernel/linux-firmware/linux-firmware-20240709-r1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sys-kernel/linux-firmware/linux-firmware-20240709-r1.ebuild b/sys-kernel/linux-firmware/linux-firmware-20240709-r1.ebuild
index eba1ddedc308..b7c47404963d 100644
--- a/sys-kernel/linux-firmware/linux-firmware-20240709-r1.ebuild
+++ b/sys-kernel/linux-firmware/linux-firmware-20240709-r1.ebuild
@@ -70,10 +70,10 @@ PATCHES=( "${FILESDIR}"/${PN}-copy-firmware-r4.patch )
pkg_pretend() {
if use initramfs; then
- if [[ -z ${ROOT} ]] && use dist-kernel; then
+ if use dist-kernel; then
# Check, but don't die because we can fix the problem and then
# emerge --config ... to re-run installation.
- nonfatal mount-boot_check_status
+ [[ -z ${ROOT} ]] && nonfatal mount-boot_check_status
else
mount-boot_pkg_pretend
fi
@@ -376,8 +376,8 @@ pkg_postinst() {
done
if use initramfs; then
- if [[ -z ${ROOT} ]] && use dist-kernel; then
- dist-kernel_reinstall_initramfs "${KV_DIR}" "${KV_FULL}"
+ if use dist-kernel; then
+ [[ -z ${ROOT} ]] && dist-kernel_reinstall_initramfs "${KV_DIR}" "${KV_FULL}"
else
# Don't forget to umount /boot if it was previously mounted by us.
mount-boot_pkg_postinst