summaryrefslogtreecommitdiff
path: root/sys-kernel/linux-docs/linux-docs-5.4.39.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/linux-docs/linux-docs-5.4.39.ebuild')
-rw-r--r--sys-kernel/linux-docs/linux-docs-5.4.39.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-kernel/linux-docs/linux-docs-5.4.39.ebuild b/sys-kernel/linux-docs/linux-docs-5.4.39.ebuild
new file mode 100644
index 000000000000..6047c3f394d0
--- /dev/null
+++ b/sys-kernel/linux-docs/linux-docs-5.4.39.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+MY_P=linux-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Developer documentation generated from the Linux kernel"
+HOMEPAGE="https://www.kernel.org/"
+SRC_URI="https://www.kernel.org/pub/linux/kernel/v5.x/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+IUSE=""
+BDEPEND="media-libs/fontconfig"
+DEPEND="<=dev-python/sphinx-2.4.4"
+RDEPEND=""
+
+src_compile() {
+ local ARCH=$(tc-arch-kernel)
+ unset KBUILD_OUTPUT
+ emake htmldocs
+}
+
+src_install() {
+ HTML_DOCS=( Documentation/output/. )
+ einstalldocs
+}