summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/Manifest.gzbin22578 -> 22576 bytes
-rw-r--r--sys-fs/safecopy/Manifest3
-rw-r--r--sys-fs/safecopy/files/safecopy-tests.patch22
-rw-r--r--sys-fs/safecopy/safecopy-1.7-r1.ebuild (renamed from sys-fs/safecopy/safecopy-1.7.ebuild)9
4 files changed, 29 insertions, 5 deletions
diff --git a/sys-fs/Manifest.gz b/sys-fs/Manifest.gz
index 46be232c7c21..98bdb4176404 100644
--- a/sys-fs/Manifest.gz
+++ b/sys-fs/Manifest.gz
Binary files differ
diff --git a/sys-fs/safecopy/Manifest b/sys-fs/safecopy/Manifest
index 1757d4f0bba5..684ef810ce79 100644
--- a/sys-fs/safecopy/Manifest
+++ b/sys-fs/safecopy/Manifest
@@ -1,3 +1,4 @@
+AUX safecopy-tests.patch 736 BLAKE2B dd10fe239af644d179a819262377f2e04bca15dee5410108f827bb1c41949cf196a302288f371ca9ad719b14677071f19a6b6a84c55d8af622cca9d4afa6d2a2 SHA512 a0eed5f58b47e380de23adf2a7e4a0c09787232f2a01cedf8e8a2dc3c58a96f3ae2f4382ecfd98d67ae7ae7fff79ea68053a5b84726c6fd6db550d79ccfb70a7
DIST safecopy-1.7.tar.gz 398465 BLAKE2B f51a164e4213441e497fc7be3f39eacd1aa8ee8064a3ad777c835e9a605eb6d6f0076b655e7a0f699be2682af59d5f61c8c33dd4c166a795fdec4a654651b216 SHA512 ecba54ecc0e0dc13dd6339f8c8dc311fc3ad41ef23318c1aa2a7f6bb7f1529389bedf7b58ea72486c083d39032a6e4a775e5a555a1ff96c669fa7fbd6c1fb868
-EBUILD safecopy-1.7.ebuild 582 BLAKE2B f97fbe3208bd920b106877bc0839355d8b1cbf20910cd421a3ba03ba769850a13212330c68373e336a5ce55f318a4c943c9a50b68bbba7e3476792f691d26cd0 SHA512 dff7f4cbae0396463fae8cf9a79176faf3048354c3407e29a1f445f309823043737c9ab05b8593794a4b7f48d0f63e7d3b9120e6bfda1ef9d4036b99b9fc1e2d
+EBUILD safecopy-1.7-r1.ebuild 627 BLAKE2B 7031aef7c66e93aaf3926f808b8149877f324227415fec5157db2c7250fd9af55f0a69ad181480f08609762aa827839ddf8abad7507e17e2b526af605ebcc819 SHA512 ae97bd44ed2341cdf793d68fbbf62c5e76622ec02a1bde8c079431272e8a6b9473c9d15c23d94b70e9927530f5214d96dc4eb6f9dd62775b28435dd6dd8b0cf5
MISC metadata.xml 616 BLAKE2B 75f8541bf34203e7e6ee41220dc7560cf574ae2132547dbec0e3b57d26a477d10b381cf27c776fb420c1be0d250f111a104dc0263be3feee9866aff39a270e71 SHA512 a17fb25dc88ffe29ff8fcb04bfd5d77145e00a0a0b2c1212f1fa3eea080f55028952aa810ac14bd53fbca7795615ae79a10935cb03f9b2f6ccfbc5627c3c394e
diff --git a/sys-fs/safecopy/files/safecopy-tests.patch b/sys-fs/safecopy/files/safecopy-tests.patch
new file mode 100644
index 000000000000..84587de17084
--- /dev/null
+++ b/sys-fs/safecopy/files/safecopy-tests.patch
@@ -0,0 +1,22 @@
+diff -Naur a/simulator/src/simulatorlb.c b/simulator/src/simulatorlb.c
+--- a/simulator/src/simulatorlb.c 2009-07-28 15:31:16.000000000 +0100
++++ b/simulator/src/simulatorlb.c 2023-09-16 13:52:16.111512487 +0100
+@@ -2,7 +2,7 @@
+ * This file is copyright ©2009 Corvus Corax
+ * Distributed under the terms of the GPL version 2 or higher
+ */
+-#define _FILE_OFFSET_BITS 64
++#define _LARGEFILE64_SOURCE
+ #include <config.h>
+
+ #ifdef USE_GNU_SOURCE
+@@ -531,3 +531,9 @@
+ }
+ return realread(fd,buf,count);
+ }
++
++// copy_file_range() may be used instead so force failure to fall back to read().
++ssize_t copy_file_range(int fd_in, off_t off_in, int fd_out, off_t off_out, size_t len, unsigned int flags) {
++ errno = EXDEV;
++ return -1;
++}
diff --git a/sys-fs/safecopy/safecopy-1.7.ebuild b/sys-fs/safecopy/safecopy-1.7-r1.ebuild
index ea11400db323..9991c27a9c67 100644
--- a/sys-fs/safecopy/safecopy-1.7.ebuild
+++ b/sys-fs/safecopy/safecopy-1.7-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-DESCRIPTION="Tool for fault-tolerant data recovery from damaged (io-errors) devices or files"
-HOMEPAGE="http://safecopy.sourceforge.net"
+DESCRIPTION="Tool for fault-tolerant data recovery from damaged (IO-errors) devices or files"
+HOMEPAGE="https://safecopy.sourceforge.net"
SRC_URI="mirror://sourceforge/safecopy/${P}.tar.gz"
LICENSE="GPL-2+"
@@ -13,6 +13,7 @@ KEYWORDS="amd64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
+PATCHES=( "${FILESDIR}"/${PN}-tests.patch )
DOCS=( README )
src_configure() {