summaryrefslogtreecommitdiff
path: root/sys-fs/zfs/zfs-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/zfs/zfs-9999.ebuild')
-rw-r--r--sys-fs/zfs/zfs-9999.ebuild22
1 files changed, 10 insertions, 12 deletions
diff --git a/sys-fs/zfs/zfs-9999.ebuild b/sys-fs/zfs/zfs-9999.ebuild
index 647324b9a308..e9d67dd0d80e 100644
--- a/sys-fs/zfs/zfs-9999.ebuild
+++ b/sys-fs/zfs/zfs-9999.ebuild
@@ -22,7 +22,7 @@ else
MY_P="${P/_rc/-rc}"
SRC_URI="https://github.com/openzfs/${PN}/releases/download/${MY_P}/${MY_P}.tar.gz"
SRC_URI+=" verify-sig? ( https://github.com/openzfs/${PN}/releases/download/${MY_P}/${MY_P}.tar.gz.asc )"
- S="${WORKDIR}/${P%_rc?}"
+ S="${WORKDIR}/${MY_P}"
if [[ ${PV} != *_rc* ]]; then
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~sparc"
@@ -37,11 +37,11 @@ SLOT="0/5"
IUSE="custom-cflags debug dist-kernel kernel-builtin minimal nls pam python +rootfs selinux test-suite"
DEPEND="
+ dev-libs/openssl:=
net-libs/libtirpc:=
sys-apps/util-linux
sys-libs/zlib
virtual/libudev:=
- dev-libs/openssl:0=
!minimal? ( ${PYTHON_DEPS} )
pam? ( sys-libs/pam )
python? (
@@ -49,7 +49,8 @@ DEPEND="
)
"
-BDEPEND="app-alternatives/awk
+BDEPEND="
+ app-alternatives/awk
virtual/pkgconfig
nls? ( sys-devel/gettext )
python? (
@@ -66,11 +67,12 @@ if [[ ${PV} != "9999" ]] ; then
fi
# awk is used for some scripts, completions, and the Dracut module
-RDEPEND="${DEPEND}
+RDEPEND="
+ ${DEPEND}
!kernel-builtin? ( ~sys-fs/zfs-kmod-${PV}:= )
!prefix? ( virtual/udev )
- sys-fs/udev-init-scripts
app-alternatives/awk
+ sys-fs/udev-init-scripts
dist-kernel? ( virtual/dist-kernel:= )
rootfs? (
app-arch/cpio
@@ -179,6 +181,9 @@ src_prepare() {
popd >/dev/null || die
fi
+ # Tries to use /etc/conf.d which we reserve for OpenRC
+ sed -i -e '/EnvironmentFile/d' etc/systemd/system/zfs*.in || die
+
# prevent errors showing up on zfs-mount stop, #647688
# openrc will unmount all filesystems anyway.
sed -i "/^ZFS_UNMOUNT=/ s/yes/no/" "etc/default/zfs.in" || die
@@ -188,13 +193,6 @@ src_configure() {
use custom-cflags || strip-flags
use minimal || python_setup
- # All the same issue:
- # Segfaults w/ GCC 12 and 'zfs send'
- # bug #856373
- # https://github.com/openzfs/zfs/issues/13620
- # https://github.com/openzfs/zfs/issues/13605
- append-flags -fno-tree-vectorize
-
local myconf=(
--bindir="${EPREFIX}/bin"
--enable-shared