summaryrefslogtreecommitdiff
path: root/sys-fs/zfs/zfs-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/zfs/zfs-9999.ebuild')
-rw-r--r--sys-fs/zfs/zfs-9999.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sys-fs/zfs/zfs-9999.ebuild b/sys-fs/zfs/zfs-9999.ebuild
index 7b38a676beca..d54b8ffe39b1 100644
--- a/sys-fs/zfs/zfs-9999.ebuild
+++ b/sys-fs/zfs/zfs-9999.ebuild
@@ -34,7 +34,7 @@ LICENSE="BSD-2 CDDL MIT"
# possible candidates: libuutil, libzpool, libnvpair. Those do not provide stable abi, but are considered.
# see libsoversion_check() below as well
SLOT="0/5"
-IUSE="custom-cflags debug dist-kernel kernel-builtin minimal nls pam python +rootfs selinux test-suite"
+IUSE="custom-cflags debug dist-kernel kernel-builtin minimal nls pam python +rootfs selinux test-suite unwind"
DEPEND="
dev-libs/openssl:=
@@ -47,6 +47,7 @@ DEPEND="
python? (
$(python_gen_cond_dep 'dev-python/cffi[${PYTHON_USEDEP}]' 'python*')
)
+ unwind? ( sys-libs/libunwind:= )
"
BDEPEND="
@@ -220,6 +221,7 @@ src_configure() {
$(use_enable nls)
$(use_enable pam)
$(use_enable python pyzfs)
+ $(use_with unwind libunwind)
--disable-static
$(usex minimal --without-python --with-python="${EPYTHON}")
)