summaryrefslogtreecommitdiff
path: root/sys-fs/zerofree/zerofree-1.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/zerofree/zerofree-1.0.1.ebuild')
-rw-r--r--sys-fs/zerofree/zerofree-1.0.1.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/sys-fs/zerofree/zerofree-1.0.1.ebuild b/sys-fs/zerofree/zerofree-1.0.1.ebuild
deleted file mode 100644
index daeafd39b4e9..000000000000
--- a/sys-fs/zerofree/zerofree-1.0.1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="4"
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Zero's out all free space on a filesystem"
-HOMEPAGE="http://intgat.tigress.co.uk/rmy/uml/index.html"
-SRC_URI="http://intgat.tigress.co.uk/rmy/uml/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86 ~mips"
-IUSE=""
-
-DEPEND="sys-libs/e2fsprogs-libs"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- # Honor system CFLAGS.
- sed -i \
- -e "s:CC=gcc:CC=$(tc-getCC)\nCFLAGS=${CFLAGS}\nLDFLAGS=${LDFLAGS}:g" \
- -e "s:-o zerofree:\$(CFLAGS) \$(LDFLAGS) -o zerofree:g" \
- -e "/-lext2fs/{ s:-lext2fs::g; s:$: -lext2fs:g; }" \
- Makefile || die "Failed to sed the Makefile"
-}
-
-src_compile() {
- # Just a Makefile, nothing fancy.
- make || die "Failed to compile ${PN}."
-}
-
-src_install() {
- # Install into /sbin
- into /
- dosbin zerofree
-}