summaryrefslogtreecommitdiff
path: root/sys-fs/xfsprogs/xfsprogs-6.6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/xfsprogs/xfsprogs-6.6.0.ebuild')
-rw-r--r--sys-fs/xfsprogs/xfsprogs-6.6.0.ebuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/sys-fs/xfsprogs/xfsprogs-6.6.0.ebuild b/sys-fs/xfsprogs/xfsprogs-6.6.0.ebuild
index eb7d1494151c..c46c41e10726 100644
--- a/sys-fs/xfsprogs/xfsprogs-6.6.0.ebuild
+++ b/sys-fs/xfsprogs/xfsprogs-6.6.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit flag-o-matic systemd udev usr-ldscript toolchain-funcs
+inherit flag-o-matic systemd udev usr-ldscript
DESCRIPTION="XFS filesystem utilities"
HOMEPAGE="https://xfs.wiki.kernel.org/ https://git.kernel.org/pub/scm/fs/xfs/xfsprogs-dev.git/"
@@ -74,6 +74,8 @@ src_configure() {
local myconf=(
--enable-static
--enable-blkid
+ # Doesn't do anything beyond adding -flto (bug #930947).
+ --disable-lto
--with-crond-dir="${EPREFIX}/etc/cron.d"
--with-systemd-unit-dir="$(systemd_get_systemunitdir)"
--with-udev-rule-dir="$(get_udevdir)"
@@ -82,12 +84,6 @@ src_configure() {
$(use_enable libedit editline)
)
- if tc-is-lto ; then
- myconf+=( --enable-lto )
- else
- myconf+=( --disable-lto )
- fi
-
econf "${myconf[@]}"
}