summaryrefslogtreecommitdiff
path: root/sys-fs/xfsdump/xfsdump-3.1.12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/xfsdump/xfsdump-3.1.12.ebuild')
-rw-r--r--sys-fs/xfsdump/xfsdump-3.1.12.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sys-fs/xfsdump/xfsdump-3.1.12.ebuild b/sys-fs/xfsdump/xfsdump-3.1.12.ebuild
index 5e4ec29587b6..ba28c411d8d8 100644
--- a/sys-fs/xfsdump/xfsdump-3.1.12.ebuild
+++ b/sys-fs/xfsdump/xfsdump-3.1.12.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="XFS dump/restore utilities"
HOMEPAGE="https://xfs.wiki.kernel.org/ https://git.kernel.org/pub/scm/fs/xfs/xfsdump-dev.git/"
@@ -58,6 +58,9 @@ src_configure() {
# bug #184564
unset PLATFORM
+ # bug 925234
+ use elibc_musl && append-flags -D_LARGEFILE64_SOURCE
+
export OPTIMIZER="${CFLAGS}"
export DEBUG=-DNDEBUG