summaryrefslogtreecommitdiff
path: root/sys-fs/udev/udev-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/udev/udev-9999.ebuild')
-rw-r--r--sys-fs/udev/udev-9999.ebuild25
1 files changed, 20 insertions, 5 deletions
diff --git a/sys-fs/udev/udev-9999.ebuild b/sys-fs/udev/udev-9999.ebuild
index 0479fe245547..49ee2cd44c17 100644
--- a/sys-fs/udev/udev-9999.ebuild
+++ b/sys-fs/udev/udev-9999.ebuild
@@ -23,13 +23,14 @@ else
# musl patches taken from:
# http://cgit.openembedded.org/openembedded-core/tree/meta/recipes-core/systemd/systemd
+ MUSL_PATCHSET="${PV}"
SRC_URI+="
elibc_musl? (
- https://dev.gentoo.org/~gyakovlev/distfiles/systemd-musl-patches-${PV}.1-r1.tar.xz
- https://dev.gentoo.org/~soap/distfiles/systemd-musl-patches-${PV}.1-r1.tar.xz
+ https://dev.gentoo.org/~gyakovlev/distfiles/systemd-musl-patches-${MUSL_PATCHSE}.tar.xz
+ https://dev.gentoo.org/~soap/distfiles/systemd-musl-patches-${MUSL_PATCHSET}.tar.xz
)"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi
DESCRIPTION="Linux dynamic and persistent device naming support (aka userspace devfs)"
@@ -82,9 +83,11 @@ RDEPEND="${COMMON_DEPEND}
acct-group/video
!sys-apps/gentoo-systemd-integration
!sys-apps/systemd
+ !sys-apps/hwids[udev]
+"
+PDEPEND="
+ >=sys-fs/udev-init-scripts-34
"
-PDEPEND=">=sys-apps/hwids-20140304[udev]
- >=sys-fs/udev-init-scripts-34"
python_check_deps() {
has_version -b "dev-python/jinja[${PYTHON_USEDEP}]"
@@ -184,6 +187,7 @@ multilib_src_compile() {
man/udev.7
man/systemd-udevd.service.8
man/udevadm.8
+ hwdb.d/60-autosuspend-chromiumos.hwdb
rules.d/50-udev-default.rules
rules.d/64-btrfs.rules
)
@@ -238,6 +242,8 @@ multilib_src_install() {
# Install generated rules (${BUILD_DIR}/rules.d/*.rules)
insinto /lib/udev/rules.d
doins rules.d/*.rules
+ insinto /lib/udev/hwdb.d
+ doins hwdb.d/*.hwdb
insinto /usr/share/pkgconfig
doins src/udev/udev.pc
@@ -262,6 +268,8 @@ multilib_src_install_all() {
insinto /lib/udev/rules.d
doins rules.d/*.rules
doins "${FILESDIR}"/40-gentoo.rules
+ insinto /lib/udev/hwdb.d
+ doins hwdb.d/*.hwdb
dobashcomp shell-completion/bash/udevadm
@@ -291,5 +299,12 @@ pkg_postinst() {
ewarn
ewarn "If you wish to disable this, please see the above documentation, or set"
ewarn "net.ifnames=0 on the kernel command line."
+ ewarn "See also: https://wiki.gentoo.org/wiki/Udev#Optional:_Disable_or_override_predictable_network_interface_naming"
+ if [[ -e ${EROOT}/etc/udev/rules.d/80-net-name-slot.rules ]]; then
+ ewarn
+ ewarn "Detected '${EROOT}/etc/udev/rules.d/80-net-name-slot.rules'"
+ ewarn "Renaming to '${EROOT}/etc/udev/rules.d/80-net-setup-link.rules'"
+ mv "${EROOT}"/etc/udev/rules.d/80-net-{name-slot,setup-link}.rules
+ fi
fi
}