summaryrefslogtreecommitdiff
path: root/sys-fs/squashfs-tools/squashfs-tools-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/squashfs-tools/squashfs-tools-9999.ebuild')
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-9999.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/sys-fs/squashfs-tools/squashfs-tools-9999.ebuild b/sys-fs/squashfs-tools/squashfs-tools-9999.ebuild
index 56e2a3332c0b..c5bf886e7767 100644
--- a/sys-fs/squashfs-tools/squashfs-tools-9999.ebuild
+++ b/sys-fs/squashfs-tools/squashfs-tools-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -34,12 +34,12 @@ DEPEND="
"
PATCHES=(
"${FILESDIR}"/${PN}-4.3-sysmacros.patch
+ "${FILESDIR}"/${PN}-4.4-fno-common.patch
)
use10() { usex $1 1 0 ; }
src_configure() {
- cd "${WORKDIR}"/${P}/${PN} || die
# set up make command line variables in EMAKE_SQUASHFS_CONF
EMAKE_SQUASHFS_CONF=(
@@ -57,11 +57,10 @@ src_configure() {
}
src_compile() {
- cd "${WORKDIR}"/${P}/${PN} || die
- emake "${EMAKE_SQUASHFS_CONF[@]}"
+ emake "${EMAKE_SQUASHFS_CONF[@]}" -C ${PN}
}
src_install() {
- dobin "${WORKDIR}"/${P}/${PN}/{mksquashfs,unsquashfs}
+ dobin ${PN}/{mksquashfs,unsquashfs}
dodoc CHANGES README RELEASE-READMEs/*
}