summaryrefslogtreecommitdiff
path: root/sys-fs/squashfs-tools/squashfs-tools-4.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/squashfs-tools/squashfs-tools-4.4.ebuild')
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-4.4.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/sys-fs/squashfs-tools/squashfs-tools-4.4.ebuild b/sys-fs/squashfs-tools/squashfs-tools-4.4.ebuild
index 4bbb6fa92af7..fcc3ce5bf79e 100644
--- a/sys-fs/squashfs-tools/squashfs-tools-4.4.ebuild
+++ b/sys-fs/squashfs-tools/squashfs-tools-4.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -10,7 +10,7 @@ SRC_URI="https://github.com/plougher/squashfs-tools/archive/${PV}.tar.gz -> ${P}
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~riscv s390 ~sh sparc x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~riscv s390 ~sh sparc x86"
IUSE="debug lz4 lzma lzo static xattr +xz zstd"
LIB_DEPEND="
@@ -30,7 +30,9 @@ DEPEND="
${RDEPEND}
static? ( ${LIB_DEPEND} )
"
-S=${WORKDIR}/${P}/${PN}
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.4-fno-common.patch
+)
use10() { usex $1 1 0 ; }
@@ -55,12 +57,11 @@ src_configure() {
}
src_compile() {
- emake "${EMAKE_SQUASHFS_CONF[@]}"
+ emake "${EMAKE_SQUASHFS_CONF[@]}" -C ${PN}
}
src_install() {
- dobin mksquashfs unsquashfs
- cd ..
+ dobin ${PN}/{mksquashfs,unsquashfs}
dodoc ACKNOWLEDGEMENTS CHANGES README*
dodoc -r RELEASE-READMEs
}