summaryrefslogtreecommitdiff
path: root/sys-fs/simple-mtpfs/simple-mtpfs-0.4.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/simple-mtpfs/simple-mtpfs-0.4.0.ebuild')
-rw-r--r--sys-fs/simple-mtpfs/simple-mtpfs-0.4.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-fs/simple-mtpfs/simple-mtpfs-0.4.0.ebuild b/sys-fs/simple-mtpfs/simple-mtpfs-0.4.0.ebuild
new file mode 100644
index 000000000000..a84aa51dbee4
--- /dev/null
+++ b/sys-fs/simple-mtpfs/simple-mtpfs-0.4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Simple MTP fuse filesystem driver"
+HOMEPAGE="https://github.com/phatina/simple-mtpfs"
+SRC_URI="https://github.com/phatina/simple-mtpfs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-libs/libmtp
+ sys-fs/fuse:0"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/autoconf-archive
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # The tarball doesn't contain ./configure, only configure.ac and
+ # autogen.sh.
+ eautoreconf
+}