summaryrefslogtreecommitdiff
path: root/sys-fs/rar2fs/rar2fs-1.27.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/rar2fs/rar2fs-1.27.0.ebuild')
-rw-r--r--sys-fs/rar2fs/rar2fs-1.27.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-fs/rar2fs/rar2fs-1.27.0.ebuild b/sys-fs/rar2fs/rar2fs-1.27.0.ebuild
new file mode 100644
index 000000000000..66afd5ece467
--- /dev/null
+++ b/sys-fs/rar2fs/rar2fs-1.27.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A FUSE based filesystem that can mount one or multiple RAR archive(s)"
+HOMEPAGE="https://hasse69.github.io/rar2fs/ https://github.com/hasse69/rar2fs"
+SRC_URI="https://github.com/hasse69/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=app-arch/unrar-5:=
+ sys-fs/fuse:0"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ export USER_CFLAGS="${CFLAGS}"
+
+ econf \
+ --with-unrar=/usr/include/libunrar \
+ --disable-static-unrar \
+ $(use_enable debug)
+}