summaryrefslogtreecommitdiff
path: root/sys-fs/quota/quota-4.06.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/quota/quota-4.06.ebuild')
-rw-r--r--sys-fs/quota/quota-4.06.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/sys-fs/quota/quota-4.06.ebuild b/sys-fs/quota/quota-4.06.ebuild
index 3ca2ad3dd987..1c4cd2de9211 100644
--- a/sys-fs/quota/quota-4.06.ebuild
+++ b/sys-fs/quota/quota-4.06.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -23,21 +23,22 @@ RDEPEND="
)
rpc? (
elibc_glibc? ( sys-libs/glibc[-rpc(-)] )
- net-libs/libtirpc
+ net-libs/libtirpc:=
net-libs/rpcsvc-proto
)
tcpd? ( sys-apps/tcp-wrappers )
"
DEPEND="${RDEPEND}"
-BDEPEND="
- nls? ( sys-devel/gettext )
-"
-PDEPEND="
- rpc? ( net-nds/rpcbind )
-"
+BDEPEND="nls? ( sys-devel/gettext )"
+PDEPEND="rpc? ( net-nds/rpcbind )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-musl-cdefs.patch
+)
src_prepare() {
default
+
eautoreconf
}
@@ -50,6 +51,7 @@ src_configure() {
$(use_enable rpc)
$(use_enable rpc rpcsetquota)
)
+
econf "${myeconfargs[@]}"
}