summaryrefslogtreecommitdiff
path: root/sys-fs/ncdu-bin/ncdu-bin-2.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/ncdu-bin/ncdu-bin-2.2.1.ebuild')
-rw-r--r--sys-fs/ncdu-bin/ncdu-bin-2.2.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/sys-fs/ncdu-bin/ncdu-bin-2.2.1.ebuild b/sys-fs/ncdu-bin/ncdu-bin-2.2.1.ebuild
new file mode 100644
index 000000000000..290db5ad4cc5
--- /dev/null
+++ b/sys-fs/ncdu-bin/ncdu-bin-2.2.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="NCurses Disk Usage"
+HOMEPAGE="https://dev.yorhel.nl/ncdu/"
+SRC_URI="
+ amd64? ( https://dev.yorhel.nl/download/ncdu-${PV}-linux-x86_64.tar.gz )
+ arm? ( https://dev.yorhel.nl/download/ncdu-${PV}-linux-arm.tar.gz )
+ arm64? ( https://dev.yorhel.nl/download/ncdu-${PV}-linux-aarch64.tar.gz )
+ x86? ( https://dev.yorhel.nl/download/ncdu-${PV}-linux-i386.tar.gz )"
+S="${WORKDIR}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64 ~x86"
+
+QA_PREBUILT="usr/bin/ncdu-bin"
+
+src_install() {
+ newbin ncdu ncdu-bin
+}