summaryrefslogtreecommitdiff
path: root/sys-fs/multipath-tools/files/multipath-tools-0.9.0-respect-flags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/multipath-tools/files/multipath-tools-0.9.0-respect-flags.patch')
-rw-r--r--sys-fs/multipath-tools/files/multipath-tools-0.9.0-respect-flags.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/sys-fs/multipath-tools/files/multipath-tools-0.9.0-respect-flags.patch b/sys-fs/multipath-tools/files/multipath-tools-0.9.0-respect-flags.patch
new file mode 100644
index 000000000000..f2b6dca05776
--- /dev/null
+++ b/sys-fs/multipath-tools/files/multipath-tools-0.9.0-respect-flags.patch
@@ -0,0 +1,15 @@
+--- a/Makefile.inc
++++ b/Makefile.inc
+@@ -140,10 +140,9 @@
+ WARNFLAGS := -Werror -Wall -Wextra -Wformat=2 $(WFORMATOVERFLOW) -Werror=implicit-int \
+ -Werror=implicit-function-declaration -Werror=format-security \
+ $(WNOCLOBBERED) -Werror=cast-qual $(ERROR_DISCARDED_QUALIFIERS)
+-CPPFLAGS := $(FORTIFY_OPT) \
+- -DBIN_DIR=\"$(bindir)\" -DMULTIPATH_DIR=\"$(plugindir)\" -DRUN_DIR=\"${RUN}\" \
++CPPFLAGS += -DBIN_DIR=\"$(bindir)\" -DMULTIPATH_DIR=\"$(plugindir)\" -DRUN_DIR=\"${RUN}\" \
+ -DCONFIG_DIR=\"$(configdir)\" -DEXTRAVERSION=\"$(EXTRAVERSION)\" -MMD -MP
+-CFLAGS := --std=gnu99 $(CFLAGS) $(OPTFLAGS) $(WARNFLAGS) -pipe
++CFLAGS += -std=gnu99 $(WARNFLAGS)
+ BIN_CFLAGS = -fPIE -DPIE
+ LIB_CFLAGS = -fPIC
+ SHARED_FLAGS = -shared