summaryrefslogtreecommitdiff
path: root/sys-fs/f2fs-tools/f2fs-tools-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/f2fs-tools/f2fs-tools-9999.ebuild')
-rw-r--r--sys-fs/f2fs-tools/f2fs-tools-9999.ebuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/sys-fs/f2fs-tools/f2fs-tools-9999.ebuild b/sys-fs/f2fs-tools/f2fs-tools-9999.ebuild
index 3224cc7ec9ff..7657d65cf872 100644
--- a/sys-fs/f2fs-tools/f2fs-tools-9999.ebuild
+++ b/sys-fs/f2fs-tools/f2fs-tools-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="Tools for Flash-Friendly File System (F2FS)"
HOMEPAGE="https://git.kernel.org/pub/scm/linux/kernel/git/jaegeuk/f2fs-tools.git/about/"
@@ -18,11 +18,11 @@ fi
LICENSE="GPL-2"
SLOT="0/10"
-IUSE="selinux"
+IUSE="lz4 lzo selinux"
RDEPEND="
- app-arch/lz4:=
- dev-libs/lzo:2
+ lz4? ( app-arch/lz4:= )
+ lzo? ( dev-libs/lzo:2 )
sys-apps/util-linux
selinux? ( sys-libs/libselinux )
elibc_musl? ( sys-libs/queue-standalone )
@@ -35,9 +35,16 @@ src_prepare() {
}
src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/863896
+ # Sent an email to linux-f2fs-devel@ but it hasn't been accepted yet...
+ filter-lto
+
local myconf=(
# This is required to install to /sbin, bug #481110
--bindir="${EPREFIX}"/sbin
+ $(use_with lz4)
+ $(use_with lzo lzo2)
$(use_with selinux)
)