summaryrefslogtreecommitdiff
path: root/sys-fs/e2tools/e2tools-0.0.16.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/e2tools/e2tools-0.0.16.4.ebuild')
-rw-r--r--sys-fs/e2tools/e2tools-0.0.16.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-fs/e2tools/e2tools-0.0.16.4.ebuild b/sys-fs/e2tools/e2tools-0.0.16.4.ebuild
new file mode 100644
index 000000000000..e869d21197a5
--- /dev/null
+++ b/sys-fs/e2tools/e2tools-0.0.16.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="utilities to read, write, and manipulate files in an ext2/ext3 filesystem"
+HOMEPAGE="http://home.earthlink.net/~k_sheff/sw/e2tools/"
+SRC_URI="https://github.com/ndim/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-fs/e2fsprogs
+ sys-libs/e2fsprogs-libs"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # The configure script is ancient.
+ #export CONFIG_SHELL="/bin/bash"
+ tc-export CC
+ default
+}