summaryrefslogtreecommitdiff
path: root/sys-fs/dmraid/dmraid-1.0.0_rc16-r7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/dmraid/dmraid-1.0.0_rc16-r7.ebuild')
-rw-r--r--sys-fs/dmraid/dmraid-1.0.0_rc16-r7.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sys-fs/dmraid/dmraid-1.0.0_rc16-r7.ebuild b/sys-fs/dmraid/dmraid-1.0.0_rc16-r7.ebuild
index f602f7a7970c..9b4b3388e2d2 100644
--- a/sys-fs/dmraid/dmraid-1.0.0_rc16-r7.ebuild
+++ b/sys-fs/dmraid/dmraid-1.0.0_rc16-r7.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools linux-info
+inherit flag-o-matic autotools linux-info
MY_PV=${PV/_/.}-3
@@ -67,6 +67,9 @@ src_prepare() {
}
src_configure() {
+ # bug 908662
+ use elibc_musl && append-flags -D_LARGEFILE64_SOURCE
+
# disable klibc and dietlibc, bug #653392
econf \
--with-usrlibdir='${prefix}'/$(get_libdir) \