summaryrefslogtreecommitdiff
path: root/sys-fs/diskdev_cmds/diskdev_cmds-332.14_p1-r4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/diskdev_cmds/diskdev_cmds-332.14_p1-r4.ebuild')
-rw-r--r--sys-fs/diskdev_cmds/diskdev_cmds-332.14_p1-r4.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/sys-fs/diskdev_cmds/diskdev_cmds-332.14_p1-r4.ebuild b/sys-fs/diskdev_cmds/diskdev_cmds-332.14_p1-r4.ebuild
index f3adae2ed197..827b33bc27b7 100644
--- a/sys-fs/diskdev_cmds/diskdev_cmds-332.14_p1-r4.ebuild
+++ b/sys-fs/diskdev_cmds/diskdev_cmds-332.14_p1-r4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
MY_PV=${PV%_p*}
@@ -29,6 +29,15 @@ PATCHES=(
)
src_compile() {
+ # -Werror=strict-alising
+ # https://bugs.gentoo.org/863893
+ # Upstream is entirely dead (since 2006!) and apple's opensource dump isn't
+ # exactly where you go to report (0) bugs to an automated feed.
+ #
+ # Do not trust with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
emake -f Makefile.lnx AR="$(tc-getAR)" CC="$(tc-getCC)"
}