summaryrefslogtreecommitdiff
path: root/sys-fs/cryptsetup/cryptsetup-2.2.0_rc0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/cryptsetup/cryptsetup-2.2.0_rc0.ebuild')
-rw-r--r--sys-fs/cryptsetup/cryptsetup-2.2.0_rc0.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/sys-fs/cryptsetup/cryptsetup-2.2.0_rc0.ebuild b/sys-fs/cryptsetup/cryptsetup-2.2.0_rc0.ebuild
index 457a33aa1fbe..e0142bdc5218 100644
--- a/sys-fs/cryptsetup/cryptsetup-2.2.0_rc0.ebuild
+++ b/sys-fs/cryptsetup/cryptsetup-2.2.0_rc0.ebuild
@@ -13,7 +13,9 @@ LICENSE="GPL-2+"
SLOT="0/12" # libcryptsetup.so version
[[ ${PV} != *_rc* ]] && \
KEYWORDS="~alpha ~amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-CRYPTO_BACKENDS="gcrypt kernel nettle +openssl"
+# cryptsetup does _not_ have a libressl backend. We only have this for REQUIRED_USE
+# and change "libressl" to "openssl" in our econf call.
+CRYPTO_BACKENDS="gcrypt kernel libressl nettle +openssl"
# we don't support nss since it doesn't allow cryptsetup to be built statically
# and it's missing ripemd160 support so it can't provide full backward compatibility
IUSE="${CRYPTO_BACKENDS} +argon2 libressl +luks1_default nls pwquality reencrypt static static-libs +udev urandom"
@@ -79,6 +81,11 @@ src_configure() {
ewarn "userspace crypto libraries."
fi
+ local x cryptobackend
+ for x in ${CRYPTO_BACKENDS//+/} ; do
+ use ${x} && cryptobackend="${x/libressl/openssl}"
+ done
+
local myeconfargs=(
--disable-internal-argon2
--enable-shared
@@ -86,7 +93,7 @@ src_configure() {
# for later use
--with-default-luks-format=LUKS$(usex luks1_default 1 2)
--with-tmpfilesdir="${EPREFIX%/}/usr/lib/tmpfiles.d"
- --with-crypto_backend=$(for x in ${CRYPTO_BACKENDS//+/} ; do usev ${x} ; done)
+ --with-crypto_backend=${cryptobackend}
$(use_enable argon2 libargon2)
$(use_enable nls)
$(use_enable pwquality)