summaryrefslogtreecommitdiff
path: root/sys-fs/cryptsetup/cryptsetup-2.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/cryptsetup/cryptsetup-2.1.0.ebuild')
-rw-r--r--sys-fs/cryptsetup/cryptsetup-2.1.0.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/sys-fs/cryptsetup/cryptsetup-2.1.0.ebuild b/sys-fs/cryptsetup/cryptsetup-2.1.0.ebuild
index c69149192442..095fb0b3fc6a 100644
--- a/sys-fs/cryptsetup/cryptsetup-2.1.0.ebuild
+++ b/sys-fs/cryptsetup/cryptsetup-2.1.0.ebuild
@@ -12,8 +12,10 @@ SRC_URI="mirror://kernel/linux/utils/${PN}/v$(ver_cut 1-2)/${P/_/-}.tar.xz"
LICENSE="GPL-2+"
SLOT="0/12" # libcryptsetup.so version
[[ ${PV} != *_rc* ]] && \
-KEYWORDS="~alpha ~amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh sparc ~x86"
-CRYPTO_BACKENDS="gcrypt kernel nettle +openssl"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86"
+# cryptsetup does _not_ have a libressl backend. We only have this for REQUIRED_USE
+# and change "libressl" to "openssl" in our econf call.
+CRYPTO_BACKENDS="gcrypt kernel libressl nettle +openssl"
# we don't support nss since it doesn't allow cryptsetup to be built statically
# and it's missing ripemd160 support so it can't provide full backward compatibility
IUSE="${CRYPTO_BACKENDS} +argon2 libressl +luks1_default nls pwquality reencrypt static static-libs +udev urandom"
@@ -79,6 +81,11 @@ src_configure() {
ewarn "userspace crypto libraries."
fi
+ local x cryptobackend
+ for x in ${CRYPTO_BACKENDS//+/} ; do
+ use ${x} && cryptobackend="${x/libressl/openssl}"
+ done
+
local myeconfargs=(
--disable-internal-argon2
--enable-shared
@@ -86,7 +93,7 @@ src_configure() {
# for later use
--with-default-luks-format=LUKS$(usex luks1_default 1 2)
--with-tmpfilesdir="${EPREFIX%/}/usr/lib/tmpfiles.d"
- --with-crypto_backend=$(for x in ${CRYPTO_BACKENDS//+/} ; do usev ${x} ; done)
+ --with-crypto_backend=${cryptobackend}
$(use_enable argon2 libargon2)
$(use_enable nls)
$(use_enable pwquality)